Package Base Details: xorg-server-git

Git Clone URL: https://aur.archlinux.org/xorg-server-git.git (read-only)
Keywords: git x-server xorg xorg-server
Submitter: ilikenwf
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 44
Popularity: 1.26
First Submitted: 2008-08-07 19:05
Last Updated: 2019-09-01 21:01

Pinned Comments

yurikoles commented on 2019-05-29 15:00

PRs are welcome: https://github.com/yurikoles-aur/xorg-server-git

hwkiller commented on 2013-03-05 04:48

Updated PKGBUILD. You were missing dri2proto, which is necessary for building xf86-video-intel-xwayland-git (otherwise, xwayland-git does not provide dri2.h).

Also notice that I don't have weston-git or wayland-git. Change if you want, but this helped me avoid pulling in all of mesa-full. It's probably not kosher to build a -git without depending on other -gits, but whatever.

http://pastie.org/private/k9ksm375iugucc1bxuwyw

moscar commented on 2013-02-14 19:58

It also depends on xorg-font-util, and glproto is a build dep. ;)

the --prefix= and DESDIR= has not been fixed in the current PKGBUILD.

ArcRaven commented on 2013-02-12 13:35

@moscar:
Done that!

moscar commented on 2013-02-12 13:29

@ArcRaven please look at cl91's comment below. He is right.
You should also be able to remove all the "|| return 1" from the PKGBUILD[1].

[1] https://bbs.archlinux.org/viewtopic.php?pid=1197999#p1197999

ArcRaven commented on 2013-02-11 17:02

@klusark, moscar:
Done, added your suggestion!
Thank you! :)

moscar commented on 2013-02-08 22:41

It also depends on the following:
fontsproto
videoproto
libxfont

moscar commented on 2013-02-08 22:41

It also depends on the following:
xorg-font-util
fontsproto
videoproto
libxfont

klusark commented on 2013-02-06 18:14

Could you add provides=('xorg-server')?

Anonymous comment on 2013-01-28 08:11

Line 31 should be
./autogen.sh --prefix=/usr
instead of
./autogen.sh --prefix=${pkgdir}/usr/

Line 37 should be
make DESTDIR="${pkgdir}" install || return 1
instead of
make install || return 1

kumquaternion commented on 2012-12-09 16:27

Please add xorg-util-macros as a dependency.