Package Base Details: xorg-server-dev

Git Clone URL: https://aur.archlinux.org/xorg-server-dev.git (read-only, click to copy)
Keywords: X-ABI-EXTENSION_VERSION X-ABI-VIDEODRV_VERSION X-ABI-XINPUT_VERSION x-server
Submitter: Det
Maintainer: ny-a
Last Packager: ny-a
Votes: 20
Popularity: 0.001593
First Submitted: 2010-06-27 07:53
Last Updated: 2021-02-01 04:14

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 13 ... Next › Last »

Det commented on 2014-04-10 09:48

Everybody's suddenly so interested in this.

jdbrown commented on 2014-04-10 09:45

The xwayland ddx mainlined recently works with --enable-xwayland flag (requires libepoxy-git, tested with weston 1.4.91). However, starting Xorg will make the screen go blank and the machine totally unresponsive on my (VMWare virtual) machine. Any ideas why?

edtoml commented on 2014-04-09 21:07

This does not work when the PGKBUILD is modified to add
--enable-glamor
which should build the version of glamor now in the xorg tree.

Its getting errors with includes and probably also needs a provides glamor-egl

(trying to test this glamor version for bug 64297)

edtoml commented on 2014-04-09 21:04

This does not seem to work when --enable-glamor is added to use the version that is now in the xorg tree. It gets errors with includes and probably need a provides glamor-egl

Det commented on 2014-04-09 17:15

Yeah, okay. It's just that they used to include those updated version clauses in the configuration step.

r08 commented on 2014-04-09 17:13

@Det based on the 2 compile errors I got during build. After installing these 2 protos everything build fine

Det commented on 2014-04-09 16:09

Thanks for going through with this.

But how did you know it was those two protos?

r08 commented on 2014-04-09 15:09

Guys if you're having build errors with this package make sure you have the bleeding-edge libraries.
Det has library packages from Git here:
https://aur.archlinux.org/packages/?K=Det&SeB=m

This particular version-1.15.99.902-1 needs fontsproto-git, xproto-git installed.

Det this PKGBUILD has an issue around lines 119-121:
mv: cannot move ‘/home/$USER/$BUILDDIR/xorg-server-dev/pkg/xorg-server-dev/usr/share/X11/xorg.conf.d/’ to ‘/home/$USER/$BUILDDIR/xorg-server-dev/pkg/xorg-server-dev/etc/X11/xorg.conf.d’: Directory not empty

I think it's best if you follow the official PKGBUILD way if installing these config files:
install -m755 -d "${pkgdir}/etc/X11"
mv "${pkgdir}/usr/share/X11/xorg.conf.d" "${pkgdir}/etc/X11/"
install -m644 "${srcdir}/10-quirks.conf" "${pkgdir}/etc/X11/xorg.conf.d/"

r08 commented on 2014-04-09 05:50

Build fail

In file included from ../include/misc.h:78:0,
from atom.c:55:
/usr/include/X11/Xdefs.h:105:10: error: expected ')' before 'OSTimePtr'
OSTimePtr /* pTimeout */,
^
In file included from atom.c:57:0:
../include/dix.h:224:54: error: expected ')' before 'WakeupHandlerProcPtr'
WakeupHandlerProcPtr
^
../include/dix.h:230:52: error: expected ')' before 'WakeupHandlerProcPtr'
WakeupHandlerProcPtr
^
atom.c: In function 'MakeAtom':
atom.c:126:26: warning: cast discards '__attribute__((const))' qualifier from pointer target type [-Wcast-qual]
free((char *) nd->string);
^
atom.c: In function 'FreeAtom':
atom.c:181:14: warning: cast discards '__attribute__((const))' qualifier from pointer target type [-Wcast-qual]
free((char *) patom->string);
^
make[2]: *** [atom.lo] Error 1
make[2]: Leaving directory `/home/jos/src/xorg/xserver-60014a4a98ff924ae7f6840781f768c1cc93bbab/dix'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/jos/src/xorg/xserver-60014a4a98ff924ae7f6840781f768c1cc93bbab/dix'
make: *** [all-recursive] Error 1

Det commented on 2014-02-25 06:48

Doesn't compile with the current dependencies, but at least I've cleaned up the PKGBUILD quite a bit.