Package Base Details: xorg-server-dev

Git Clone URL: https://aur.archlinux.org/xorg-server-dev.git (read-only, click to copy)
Keywords: X-ABI-EXTENSION_VERSION X-ABI-VIDEODRV_VERSION X-ABI-XINPUT_VERSION x-server
Submitter: Det
Maintainer: ny-a
Last Packager: ny-a
Votes: 20
Popularity: 0.085282
First Submitted: 2010-06-27 07:53
Last Updated: 2020-03-30 01:31

Det commented on 2010-07-09 23:49

Minor grammatical pedantism. No need to bump the pkgrel.

Det commented on 2010-07-03 17:39

Don't use the new RC(4) until your video driver starts supporting it: http://lists.freedesktop.org/archives/xorg/2010-July/050640.html

Det commented on 2010-07-02 17:57

New Nvidia driver users:
http://lists.freedesktop.org/archives/xorg/2010-July/050641.html

Det commented on 2010-07-02 17:16

The 1.9RC4 doesn't work with Nvidia driver. The reason is not with the xorg-server's mi overlay support, as I thought it was. Here's my question and the answer I got in the mailing list:
http://lists.freedesktop.org/archives/xorg/2010-July/050641.html

Det commented on 2010-07-02 17:16

The 1.9RC4 doesn't work with Nvidia driver. The reason is not with the xorg-server's mi overlay support, as I thought it was. Here's my question in the mailing list:
http://lists.freedesktop.org/archives/xorg/2010-July/050641.html

Det commented on 2010-07-02 17:15

The 1.9RC4 doesn't work with Nvidia, the reason is not with the mi overlay, as I thought it was. Here's my question in the mailing list:
http://lists.freedesktop.org/archives/xorg/2010-July/050641.html

Det commented on 2010-07-02 16:19

As 1.9 RC2, Xorg server RC4 doesn't support the 'mi overlay' that Nvidia driver uses and reports it like this when starting X (start, xinit, dm, whatever):
dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol: WindowTable

More reading:
http://www.phoronix.com/scan.php?page=news_item&px=ODM1Nw
http://lists.freedesktop.org/archives/xorg/2010-June/050547.html

There was no sign of the 'mi overlay' support conversation in here, though (so I started one):
http://lists.freedesktop.org/archives/xorg/2010-July/

Det commented on 2010-07-02 15:58

As 1.9 RC2, Xorg server RC4 doesn't support the 'mi overlay' that Nvidia driver uses and reports it like this when starting X (start, xinit, dm, whatever):
dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol: WindowTable

More reading:
http://www.phoronix.com/scan.php?page=news_item&px=ODM1Nw
http://lists.freedesktop.org/archives/xorg/2010-June/050547.html

No sign of the 'mi overlay' support conversation in here, though:
http://lists.freedesktop.org/archives/xorg/2010-July/

Det commented on 2010-07-02 15:58

As 1.9 RC2, RC4 doesn't support the 'mi overlay' that Nvidia driver uses and reports it like this when starting X (start, xinit, dm, whatever):
dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: undefined symbol: WindowTable

More reading:
http://www.phoronix.com/scan.php?page=news_item&px=ODM1Nw
http://lists.freedesktop.org/archives/xorg/2010-June/050547.html

No sign of the 'mi overlay' support conversation in here, though:
http://lists.freedesktop.org/archives/xorg/2010-July/

Det commented on 2010-07-02 06:39

Bump to 1.9 RC4.