Package Base Details: xorg-server-dev

Git Clone URL: https://aur.archlinux.org/xorg-server-dev.git (read-only, click to copy)
Keywords: X-ABI-EXTENSION_VERSION X-ABI-VIDEODRV_VERSION X-ABI-XINPUT_VERSION x-server
Submitter: Det
Maintainer: ny-a
Last Packager: ny-a
Votes: 20
Popularity: 0.000714
First Submitted: 2010-06-27 07:53
Last Updated: 2021-02-01 04:14

Latest Comments

« First ‹ Previous ... 9 10 11 12 13 14 15 16 17 18 19 ... Next › Last »

Anonymous comment on 2011-01-09 10:57

xextproto-git randrproto-git are required

[update]

something else is wrong with the pkgbuild, I could build the src itself with ./configure and just make and everything works fine but when I try it with the pkgbuild it fails.

Det commented on 2010-12-10 17:02

SYNOPSIS (to combine two long posts): I've now uploaded all that *proto stuff here in AUR (used in the build) as Git versions. I've also since fixed the non-working *proto packages that all got the same "validation" error.

Until the new xext-/ranrdproto's will be released this package uses their git versions (since the new Xorg server (1.10 RC1) requires 'randrproto>=1.4.0' and 'xextproto>=7.1.99').

I've just now also fixed this one (the server itself) as in the end it also got the same "validation" error.

E: Just remember that because of the new ABIs there is currently no working driver for the new Xorg server. I just confirmed here with the Nvidia driver (260.19.26) that even the "-ignoreABI" flag doesn't help.

Det commented on 2010-12-10 16:57

SYNOPSIS (to combine two long posts): I've now uploaded all that *proto stuff here in AUR (used in the build) as Git versions. I've also since fixed the non-working *proto packages that all got the same "validation" error.

Until the new xext-/ranrdproto's will be released this package uses their git versions (since the new Xorg server (1.10 RC1) requires 'randrproto>=1.4.0' and 'xextproto>=7.1.99').

I've just now also fixed the this one (the Xorg server itself) as in the end it also got the same "validation" error.

E: Just remember that because of the new ABIs there is currently no working driver for the new Xorg server. I just confirmed here with the Nvidia driver (260.19.26) that even the "-ignoreABI" flag doesn't help.

Det commented on 2010-12-10 16:16

SYNOPSIS (to combine two long posts): I've now uploaded all that *proto stuff here in AUR (used in the build) as Git versions. I've also since fixed the non-working *proto packages that all got the same "validation" error.

Until the new xext-/ranrdproto's will be released this package uses their git versions (since the new Xorg server (1.10 RC1) requires 'randrproto>=1.4.0' and 'xextproto>=7.1.99').

I've just now also fixed the this one (the Xorg server itself) as in the end it also got the same "validation" error.

Det commented on 2010-12-10 16:15

SYNOPSIS (to combine two long posts): I've now uploaded all that *proto stuff here in AUR (used in the build) as Git versions. I've also since fixed the non-working *proto packages that all got the same "validation" error.

Until the new xext-/ranrdproto's will be released this package uses their git versions since the new Xorg server (1.10 RC1) requires 'randrproto>=1.4.0' and 'xextproto>=7.1.99'.

I've just now also fixed the same validation error this one gets in the build (the Xorg server itself).

Det commented on 2010-12-10 16:15

SYNOPSIS (to combine two long posts): I've now uploaded all that *proto stuff here in AUR (used in the build) as Git versions. I've also since fixed the non-working *proto packages that all got the same "validation" error.

Until new xext-/ranrdproto's will be released this package uses their git versions since the new Xorg server (1.10 RC1) requires 'randrproto>=1.4.0' and 'xextproto>=7.1.99'.

I've just now also fixed the same validation error this one gets in the build (the Xorg server itself).

Det commented on 2010-12-10 16:14

SYNOPSIS (to combine two long posts): I've now uploaded all that *proto stuff here in AUR (used in the build) as Git versions. I've also since fixed the non-working *proto packages that all get the same "validation" error.

Until new xext-/ranrdproto's will be released this package uses their git versions since the new Xorg server (1.10 RC1) requires 'randrproto>=1.4.0' and 'xextproto>=7.1.99'.

I've just now also fixed the same validation error this one gets in the build (the Xorg server itself).

Det commented on 2010-12-10 16:14

Synapsis (to combine two long posts): I've now uploaded all that *proto stuff here in AUR (used in the build) as Git versions. I've also since fixed the non-working *proto packages that all get the same "validation" error.

Until new xext-/ranrdproto's will be released this package uses their git versions since the new Xorg server (1.10 RC1) requires 'randrproto>=1.4.0' and 'xextproto>=7.1.99'.

I've just now also fixed the same validation error this one gets in the build (the Xorg server itself).1

Det commented on 2010-12-07 21:32

UPDATE: I've now uploaded randrproto-git and xextproto-git (along with a lot of other *proto stuff) but sadly, as it seems, xextproto-git doesn't compile at the moment. Actually a few hours ago every other of these packages I uploaded did but now a lot of them are beginning to get the same error too.

So maybe those commits will be reverted or a new workaround implemented. Who knows..

Det commented on 2010-12-07 09:33

NOTE: 1.10 RC1 doesn't build until randrproto and xextproto in the repos will be updated (until the new ones will be released).

I've left the "old" 1.9.3 RC2 pkgver & md5sums to the PKGBUILD in case somebody wants to still use the absolute latest bleeding edge xorg-server ;). Just remember that your AUR helper (whatever it is) will constantly be updating this package because of the higher pkgver.