Package Base Details: xorg-server-dev

Git Clone URL: https://aur.archlinux.org/xorg-server-dev.git (read-only, click to copy)
Keywords: X-ABI-EXTENSION_VERSION X-ABI-VIDEODRV_VERSION X-ABI-XINPUT_VERSION x-server
Submitter: Det
Maintainer: ny-a
Last Packager: ny-a
Votes: 20
Popularity: 0.000685
First Submitted: 2010-06-27 07:53
Last Updated: 2021-02-01 04:14

Latest Comments

« First ‹ Previous ... 7 8 9 10 11 12 13 14 15 16 17 ... Next › Last »

karabaja4 commented on 2011-07-03 20:37

Little help with this please:

================ WARNING WARNING WARNING WARNING ================
This server has a video driver ABI version of 11.0 that this
driver does not officially support. Please check
http://www.nvidia.com/ for driver updates or downgrade to an X
server with a supported driver ABI.
=================================================================
(WW) NVIDIA: The driver will continue to load, but may behave strangely.
(WW) NVIDIA: This driver was compiled against the X.Org server SDK from git commit b6c7b9b2f39e970cedb6bc1e073f901e28cb0fa3 and may not be compatible with the final version of this SDK.
(WW) NVIDIA: This server has an unsupported input driver ABI version (have 13.0, need < 13.0). The driver will continue to load, but may behave strangely.
(WW) module ABI major version (12) doesn't match the server's version (13)

and my xorg doesn't load (kinda freezes), that's using 280.04 nvidia binary driver?

Det commented on 2011-07-01 22:31

And of course, the input ABI of the new X server is v13 - the _video_ ABI is v11.

Det commented on 2011-06-30 17:37

Actually, don't bother. The new X server _sucks_. Or at least it does so with the latest nvidia driver (transparency issues, content of other windows is displayed in others, etc.).

Det commented on 2011-06-30 08:20

Finally. The nvidia driver 280.04 supports the new ABI, thus it supports the new X server 1.11 series.

Det commented on 2011-06-01 22:05

A lot of juicy changes with 1.11 RC1. All the 'extra patches' from [extra]'s xorg-server are included (in the sources) (with the exception of the 'die-ugly-pattern' fix).

Changelog: http://www.spinics.net/lists/xorg/msg52652.html

E: but of course, remember that if your video driver's ABI hasn't been bumped to this (13.0), you won't be able to use it. Nvidia driver 275.09's ABI is 12.0 and it didn't work even with force-loading.

Det commented on 2011-06-01 22:01

A lot of juicy fixes with 1.11 RC1. All the 'extra patches' from [extra]'s xorg-server are included (in the sources) (with the exception of the 'die-ugly-pattern' fix).

Changelog: http://www.spinics.net/lists/xorg/msg52652.html

Det commented on 2011-05-30 21:15

Synced with [extra]'s(/[testing]'s) xorg-server changes:

[extra]: Add latest fixes from upstream 1.10 branch
Patch autoconfig to use nouveau/nv/nvidia instead of only nv

([testing]: Build with mesa and resourceproto from testing)

Det commented on 2011-05-29 09:27

1.10.2: http://lists.freedesktop.org/pipermail/xorg/2011-May/053143.html

Det commented on 2011-05-21 07:37

1.10.1.902 (1.10.2 RC2): http://www.mail-archive.com/xorg@lists.freedesktop.org/msg14243.html

Det commented on 2011-05-07 15:44

1.10.1.901 (1.10.2 RC1). Release notes for the excited: http://www.mail-archive.com/xorg@lists.freedesktop.org/msg14173.html