Package Base Details: vmware-horizon-client

Git Clone URL: https://aur.archlinux.org/vmware-horizon-client.git (read-only, click to copy)
Submitter: eworm
Maintainer: eworm
Last Packager: eworm
Votes: 36
Popularity: 1.08
First Submitted: 2015-01-08 15:17
Last Updated: 2020-08-11 16:00

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 Next › Last »

Muflone commented on 2015-07-31 08:58

I've got the same issues.
Is there some workaround, like downgrade?

eworm commented on 2015-07-16 14:56

The issue is triggered by (lib32-)openssl 1.0.2d. The commit in question is:
http://git.openssl.org/?p=openssl.git;h=692f07c3e0c04180b56febc2feb57cd94395a7a2

I've contacted VMware, let's see if/when we will see an updated release. For now you can compile (lib32-)openssl with the commit reverted.

debugrr commented on 2015-07-16 14:06

It was working fine, until I did a pacman -Syu and rebooted yesterday.

debugrr commented on 2015-07-16 14:06

Anyone seen thise issue?
I just reinstalled all the deps and tried installing from scratch -- still getting this.

It' pops up for a second then dies with this.
------------------------
2015-07-16 09:04:21.695-05:00: vmware-view 31314| CdkDebug_PrintErr: **
ERROR:/build/mts/release/bora-2769709/maug/view/openClient/lib/cdk/cdkSslOpenSsl.c:405:CdkSsl_Verify: code should not be reached

/usr/bin/vmware-view: line 102: 31314 Aborted (core dumped) "$binPath/bin/vmware-view" "$@"
-----------------------

eworm commented on 2015-04-23 08:08

Mountainerd, glad to hear that you are happy with this package. ;)

Well, kind of at least... No idea about the sound. For me it just works. You could take a look at /tmp/vmware-$USER/vmware-mks-$PID.log, perhaps you can find some hints there.

Mountainerd commented on 2015-04-22 17:24

Hey eworm - thanks for keeping this package up-to-date. I use it daily for work on my Arch box.

I am curious if you can help point me in the right direction as to why I cannot get sound from my Win 7 desktop to come through on my end. Sound works on my local machine, I installed the 32-bit drivers for ALSA, made sure the VM had the drivers installed, but no joy yet.

Thanks!

Muflone commented on 2015-03-28 11:58

That's not correct.
I had the vmware-horizon-client package for ages and worked fine until the last update. I'm not sure if in the past I installed the vmware-horizon-virtual-printing package, therefore the source of the issue could be the first install of that package.

However FYI the issue is due to yaourt which doesn't properly parse the depends_arch variable, the same issue applies on others packages.

eworm commented on 2015-03-25 18:37

Ah, I think I know what your problem is. You never had vmware-horizon-client 3.2.0-5 or any other version installed, no?

So the issue is not depends_x86_64=() array, which works just fine on its own. makepkg does not expext dependencies added in split packages package() function to be installed. In this case it is fine for building as binaries are not compiled but installed as-is.

So just build and install the missing packages manually.

Muflone commented on 2015-03-25 16:06

I do have pacman 4.2.1-1 but pacman never installs packages from the AUR and simply refuses to install the package if openssl098 or lib32-pcsclite aren't installed before.

Maybe it would be duty of yaourt or any other AUR manager to install dependencies from depends_arch variable.

eworm commented on 2015-03-25 15:59

Just tested that and works for me. All packages have their dependencies set as expected. Is your pacman package up-to-date? Should be 4.2.1-1.

Or did I get you wrong?