Package Base Details: vmware-horizon-client

Git Clone URL: https://aur.archlinux.org/vmware-horizon-client.git (read-only, click to copy)
Submitter: eworm
Maintainer: eworm
Last Packager: eworm
Votes: 31
Popularity: 0.098450
First Submitted: 2015-01-08 15:17
Last Updated: 2020-03-18 16:14

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 Next › Last »

billbrown commented on 2016-03-10 15:25

Hi. I was getting an "undefined symbol: SSLv2_method" error when trying to start the latest build of this project. I was able to downgrade openssl to get the app working:

pacaur -U /var/cache/pacman/pkg/openssl-1.0.2.f-1-i686.pkg.tar.xz

This is my linux build
Linux arch 4.4.3-1-ARCH #1 SMP PREEMPT Fri Feb 26 15:25:21 CET 2016 i686 GNU/Linux

Maybe that will help others until this is fixed.



iozen commented on 2016-01-12 16:30

/usr/lib/vmwareview/usb-vmware-view-usbd failed with the following output error :

SSLLoadSharedLibraries: Failed to load OpenSSL libraries. libdir is /usr/lib/vmware

VMware Horizon View client USB service Error:
VMware Horizon View client USB service unrecoverable error: (vmware-usbd)
SSLLoadSharedLibraries: Failed to load OpenSSL libraries. libdir is /usr/lib/vmware

jskier commented on 2015-09-04 14:49

Thanks, but on an updated system, I get this (if I symlink it moves on to other crypt libs):
/usr/lib/vmware/view/bin/vmware-view: error while loading shared libraries: libssl.so.1.0.2: cannot open shared object file: No such file or directory

eworm commented on 2015-09-04 07:34

Updated to version 3.5.0, which brings native x86_64 package and solves the openssl issue!

s_root commented on 2015-08-25 09:26

getting this error....
error: failed to prepare transaction (could not satisfy dependencies)
:: vmware-horizon-client: requires lib32-libpng12
:: vmware-horizon-client: requires lib32-libpng12
:: vmware-horizon-pcoip: requires vmware-horizon-client
:: vmware-horizon-client: requires lib32-libpng12
:: vmware-horizon-rtav: requires vmware-horizon-client
:: vmware-horizon-client: requires lib32-libpng12
:: vmware-horizon-smartcard: requires vmware-horizon-client
:: vmware-horizon-smartcard: requires lib32-pcsclite
:: vmware-horizon-client: requires lib32-libpng12
:: vmware-horizon-usb: requires vmware-horizon-client
:: vmware-horizon-client: requires lib32-libpng12
:: vmware-horizon-virtual-printing: requires vmware-horizon-client
:: vmware-horizon-virtual-printing: requires openssl098
==> WARNING: Your packages are saved in /tmp/yaourt-tmp-sr

Henry78 commented on 2015-08-12 07:49

I face the same problem as shkercuh.

pcoip files are only extracted, if the subpackage pcoip is installed. When building the other subpackages (e.b. -client, -usb, ...) with yaourt --pkg $PKG -S $PKG the vmware-horizon-pcoip isn't extracted from the bundle an therefore the removal in PKGBUILD line #70 can't work.

eworm commented on 2015-08-11 19:47

Works for me... Just verified. These file belong to the package and I remove them by intention.

Can you tell me what happens on your system?

shkercuh commented on 2015-08-11 18:01

Errors when building (bypassed by removing https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=vmware-horizon-client#n70):

rm: cannot remove ‘/tmp/yaourt-tmp-l/aur-vmware-horizon-client/src/extract/vmware-horizon-pcoip/pcoip/lib/vmware/libcrypto.so.1.0.1’: No such file or directory
rm: cannot remove ‘/tmp/yaourt-tmp-l/aur-vmware-horizon-client/src/extract/vmware-horizon-pcoip/pcoip/lib/vmware/libssl.so.1.0.1’: No such file or directory

festerman commented on 2015-08-01 14:55

Rolling back to 1.0.2c also works. Beware, tho, both workrounds re-opens a vulnerability.

festerman commented on 2015-08-01 14:53

Rolling back to 1.0.2c works, but re-opens the plugged security hole ...