Package Base Details: tuxguitar

Git Clone URL: https://aur.archlinux.org/tuxguitar.git (read-only)
Submitter: Barthalion
Maintainer: buzo
Last Packager: buzo
Votes: 37
Popularity: 2.085129
First Submitted: 2018-01-05 17:06
Last Updated: 2019-08-06 11:04

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

nobrakal commented on 2018-08-06 17:42

Thanks for the ping @thegovernor !

The package was also out-of-date. It is now updated to the latest 1.5.2.

thegovernor commented on 2018-08-06 15:38

Hello,

The package checksums seem to be out of date.

yay output:

Validating source files with sha256sums... tuxguitar-1.5.1-src.tar.gz ... FAILED

If possible, please update the package. Thank you.

raith commented on 2018-06-18 12:46

Thank you very much for the explanation.

I've just installed the package, but adjusted a few things beforehand in the PKGBUILD: - exchanged gtk2 with gtk3 - updated to tuxguitar 1.5.1 - added conflicts + provides to let pacman react correctly, if the other tuxguitar package is installed

Patchfile with these changes: https://pastebin.com/G6bKcq0A

lucidvillain666 commented on 2018-06-18 03:52

Thank you for pointing out the dependency issue. I apologize for this. As for the differences between this and the main tuxguitar package (which used to be in the community repository, mind you), is that it doesn't set tuxguitar to use GTK 2. The tuxguitar binary uses GTK 3 by default, but due to an issue that was a problem way back in time, GTK 2 was used instead using a variable in a shell script that exists in /usr/bin as 'tuxguitar'. The package continued this behavior beyond its necessity, and so because I got sick of manually changing this behavior with every update, I decided to create an AUR package, and yes, I used the same PKGBUILD as a base. I need to change the GTK dependency for sure, but the actual difference is in the launcher shell script that is called when running 'tuxguitar'. I hope this cleared things up, and hopefully I can have the package updated by tomorrow to correct the dependencies.

raith commented on 2018-06-17 11:40

Shouldn't the package depend on gtk3 instead of gtk2?

What's the difference to the other tuxguitar package here on AUR? The PKGBUILDs of both don't have any significant differences.

ArnaudNux commented on 2018-05-27 22:08

BUILD FAILED
/home/arnaud/tempo/gcc5/javahelp2/src/javahelp2/javahelp_nbproject/build.xml:104: The following error occurred while executing this line:
/home/arnaud/tempo/gcc5/javahelp2/src/javahelp2/JSearchIndexer_nbproject/nbproject/build-impl.xml:314: The following error occurred while executing this line:
/home/arnaud/tempo/gcc5/javahelp2/src/javahelp2/JSearchClient_nbproject/nbproject/build-impl.xml:314: The following error occurred while executing this line:
/home/arnaud/tempo/gcc5/javahelp2/src/javahelp2/javahelp_nbproject/nbproject/build-impl.xml:598: The following error occurred while executing this line:
/home/arnaud/tempo/gcc5/javahelp2/src/javahelp2/javahelp_nbproject/nbproject/build-impl.xml:244: Unable to find a javac compiler;
com.sun.tools.javac.Main is not on the classpath.
Perhaps JAVA_HOME does not point to the JDK.
It is currently set to "/usr/lib/jvm/java-8-openjdk/jre"

Total time: 0 seconds
==> ERROR: A failure occurred in build().
    Aborting...

raith commented on 2018-05-24 19:06

@Enelar: Seems like you are using "jre8-openjdk" as JRE, so you need "jdk8-openjdk" to successfully build the tuxguitar package.

Tuxguitar works with many Java versions, so you need to make sure, your using the same version for JRE and JDK when creating the package.

Enelar commented on 2018-05-24 13:47

[ERROR] COMPILATION ERROR : [INFO] ------------------------------------------------------------- [ERROR] Unable to locate the Javac Compiler in: /usr/lib/jvm/java-8-openjdk/jre/../lib/tools.jar Please ensure you are using JDK 1.4 or above and not a JRE (the com.sun.tools.javac.Main class is required). In most cases you can change the location of your Java installation by setting the JAVA_HOME environment variable.

Wrong dependencies - i instailed adviced 10, and it wont built. Update package please

nobrakal commented on 2018-05-11 08:14

The 1.5.1 is out, I hope that fix the problem. It build fine with java-10-openjdk on my machine.

pdimens commented on 2018-05-09 15:04

I wanted to add that this package only seems to build with JDK9 installed. I have JDK10 and it kept failing, but haven't tried with JDK8.