Package Base Details: sqlitestudio

Git Clone URL: https://aur.archlinux.org/sqlitestudio.git (read-only)
Submitter: dracorp
Maintainer: dracorp
Last Packager: dracorp
Votes: 13
Popularity: 0.006724
First Submitted: 2012-11-22 08:28
Last Updated: 2018-08-29 16:33

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

Romzetron commented on 2015-10-07 02:48

I have Qt5.5 installed and ran into the same error when building the package. After a little research, I found that <QDataStream> needs to be included explicitly. The include was implied in previous version of Qt. I opened up the project in qtcreator, compiled, and found that the following files were missing "#include <QDataStream>". After patching up the source in the package, it built and installed successfully.

src/SQLiteStudio3/coreSQLiteStudio/common/utils.cpp
src/SQLiteStudio3/coreSQLiteStudio/db/db.cpp
src/SQLiteStudio3/sqlitestudiocli/cli_config.cpp

bhrgunatha commented on 2015-09-29 03:48

I have qt5-svg and qt5-tools installed, but I'm still getting a compilation error.

../../../SQLiteStudio3/coreSQLiteStudio/common/utils.cpp: In function ‘QByteArray hashToBytes(const QHash<QString, QVariant>&)’:
../../../SQLiteStudio3/coreSQLiteStudio/common/utils.cpp:321:23: error: variable ‘QDataStream stream’ has initializer but incomplete type
QDataStream stream(&bytes, QIODevice::WriteOnly);
^
../../../SQLiteStudio3/coreSQLiteStudio/common/utils.cpp: In function ‘QHash<QString, QVariant> bytesToHash(const QByteArray&)’:
../../../SQLiteStudio3/coreSQLiteStudio/common/utils.cpp:332:29: error: variable ‘QDataStream stream’ has initializer but incomplete type
QDataStream stream(bytes);
^
Makefile:2864: recipe for target 'utils.o' failed
make[1]: *** [utils.o] Error 1
make[1]: Leaving directory ...
Makefile:45: recipe for target 'sub-coreSQLiteStudio-make_first' failed
make: *** [sub-coreSQLiteStudio-make_first] Error 2


Looks like it's related to Qt... any ideas?
Am I missing another dependency?

dracorp commented on 2015-05-20 16:05

Yes, it is good idea. Thx awpe.

awpe commented on 2015-05-20 10:15

Hi, for those who have compile problem:

$Project ERROR: Unknown module(s) in QT: uitools
$Makefile:70: recipe for target 'sub-guiSQLiteStudio-make_first' failed

just install qt5-tools.

Maybe it is good idea to add this package to dep-list? :)

claymore commented on 2015-02-26 22:40

Yeah, I noticed that and already installed it. Compiling now!

Thanks anyway :)

dracorp commented on 2015-02-26 22:37

Missing qt5-svg in makedepends, sorry about this but namcap doesn't inform about dependencies needed for building and I missed it.

claymore commented on 2015-02-26 22:24

It fails to compile. Any ideas?

cd guiSQLiteStudio/ && ( test -e Makefile || /usr/lib/qt/bin/qmake /tmp/yaourt-tmp-claymore/aur-sqlitestudio/src/SQLiteStudio3/guiSQLiteStudio/guiSQLiteStudio.pro -o Makefile ) && make -f Makefile
Project ERROR: Unknown module(s) in QT: svg
Makefile:70: recipe for target 'sub-guiSQLiteStudio-make_first' failed
make: *** [sub-guiSQLiteStudio-make_first] Error 3
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build .
==> Restart building sqlitestudio ? [y/N]
==> -------------------------------------
==>

dracorp commented on 2015-02-26 20:53

Upgraded to version 3.0.3.

dracorp commented on 2015-02-25 09:52

I disowned package. Someone can adopt and upgrade it.
If nobody update the program I'll do this in my free time.
Sorry about this.

dracorp commented on 2015-01-31 19:16

Forgive me for such a long time to wait. Version 3.0.1 had a bug and 3.0.2 compiles successfully.
I don't have enough time lately so if someone needs can adopt this package.