Package Base Details: sozi

Git Clone URL: https://aur.archlinux.org/sozi.git (read-only, click to copy)
Submitter: linkmauve
Maintainer: sbmomeni
Last Packager: sbmomeni
Votes: 73
Popularity: 0.000002
First Submitted: 2010-10-28 11:53
Last Updated: 2019-08-14 17:43

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

sbmomeni commented on 2018-02-10 12:03

@rplanchuelo: fixed.

rplanchuelo commented on 2018-02-10 11:33

Maybe it isn't neccesary. From https://www.npmjs.com/package/acorn5-object-spread:

acorn5-object-spread Spread and rest properties support in acorn 5

NPM version

Since spread and rest properties are part of ECMAScript 2018, acorn now supports them out of the box. Just make sure that you use acorn >= 5.4.1 and set ecmaVersion >= 9. This plugin is deprecated.

rplanchuelo commented on 2018-02-10 11:29

I cann't update because there is a error with acorn5-object-spread-5.0.1.tgz:

% Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed 0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0 Warning: Transient problem: HTTP error Will retry in 3 seconds. 3 retries Warning: left. 0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0 Warning: Transient problem: HTTP error Will retry in 3 seconds. 2 retries Warning: left. 0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0 Warning: Transient problem: HTTP error Will retry in 3 seconds. 1 retries Warning: left. 0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0 curl: (22) The requested URL returned error: 500 ==> ERROR: Hubo fallos durante la descarga de https://registry.npmjs.org/@browserify%2facorn5-object-spread/-/acorn5-object-spread-5.0.1.tgz

macxcool commented on 2017-12-12 11:32

@sbmomeni Thanks for the explanation. I appreciate it. I may try a bin package, just for the fun of it ;-)

sbmomeni commented on 2017-12-12 10:51

@macxcool Now that our installation script is merged in upstream repo, a "-bin" package can use that approach. But it does not necessarily work as the ArchLinux continues updating. For example, we had to use a different electron version previously.

a1rolo commented on 2017-09-08 01:10

Same error as mathiew.clabaut

==> ERROR: A failure occurred in build().
Aborting...

mathieu.clabaut commented on 2017-08-21 08:27

Thank @sbmomeni.

Alas, I now get :
==> bower install completed successfully
module.js:491
throw err;
^

Error: Cannot find module 'getobject'
at Function.Module._resolveFilename (module.js:489:15)
at Function.Module._load (module.js:439:25)
at Module.require (module.js:517:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/tmp/yaourt-tmp-clabaut/aur-sozi/src/Sozi-17.06/node_modules/grunt-legacy-util/index.js:20:18)
at Module._compile (module.js:573:30)
at Object.Module._extensions..js (module.js:584:10)
at Module.load (/tmp/yaourt-tmp-clabaut/aur-sozi/src/Sozi-17.06/node_modules/coffee-script/lib/coffee-script/register.js:45:36)
at tryModuleLoad (module.js:470:12)
at Function.Module._load (module.js:462:3)
at Module.require (module.js:517:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/tmp/yaourt-tmp-clabaut/aur-sozi/src/Sozi-17.06/node_modules/grunt/lib/grunt.js:17:12)
at Module._compile (module.js:573:30)
at Object.Module._extensions..js (module.js:584:10)
at Module.load (module.js:507:32)
at tryModuleLoad (module.js:470:12)
at Function.Module._load (module.js:462:3)
at Module.require (module.js:517:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/usr/lib/node_modules/grunt-cli/bin/grunt:44:1)
at Module._compile (module.js:573:30)
at Object.Module._extensions..js (module.js:584:10)
at Module.load (module.js:507:32)
at tryModuleLoad (module.js:470:12)
at Function.Module._load (module.js:462:3)
at Function.Module.runMain (module.js:609:10)
at startup (bootstrap_node.js:158:16)
at bootstrap_node.js:578:3

==> ERROR: A failure occurred in build().
Aborting...

Maybe @macxcool suggestion would be a good alternative ?

macxcool commented on 2017-07-27 21:36

I'm just curious. Why wouldn't I download the Sozi tarball, untar it into /opt and run Sozi from there rather than do all this npm installation every time?

sbmomeni commented on 2017-07-27 20:14

@mathieu.clabaut
droid_sans source is now replaced with make-dependency to ttf-droid package.

mathieu.clabaut commented on 2017-07-27 07:23

Error when downloading droid_sans :

-> Downloading droid_sans.zip...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (22) The requested URL returned error: 403 Forbidden
==> ERROR: Failure while downloading http://www.1001freefonts.com/d/5854/droid_sans.zip

Wouldn't be possible to just make a dependency upon the ttf-droid package ?