Package Base Details: rust-git

Git Clone URL: https://aur.archlinux.org/rust-git.git (read-only, click to copy)
Keywords: mozilla rust
Submitter: mrshpot
Maintainer: spider-mario (ishitatsuyuki)
Last Packager: ishitatsuyuki
Votes: 26
Popularity: 0.000166
First Submitted: 2012-01-21 11:30
Last Updated: 2018-02-11 11:49

Latest Comments

1 2 3 4 5 6 ... Next › Last »

groctel commented on 2021-05-12 12:43

Why does this package install unnecessary rust-*-git dependencies by building them instead of relying on actual AUR dependencies? This package should just provide the rust language server.

A.J commented on 2020-02-03 23:51

build fails with the following error :

error: failed to run custom build command for profiler_builtins v0.0.0 (/home/aj/Downloads/rust-git/src/rust/src/libprofiler_builtins)

Caused by: process didn't exit successfully: /home/aj/Downloads/rust-git/src/rust/build/x86_64-unknown-linux-gnu/stage0-std/release/build/profiler_builtins-1d8d0e4ced679e9e/build-script-build (exit code: 101) --- stderr thread 'main' panicked at 'called Option::unwrap() on a None value', /rustc/eb3f7c2d3aec576f47eba854cfbd3c1187b8a2a0/src/libcore/macros/mod.rs:15:40 note: run with RUST_BACKTRACE=1 environment variable to display a backtrace.

warning: build failed, waiting for other jobs to finish... error: build failed

spider-mario commented on 2019-10-21 08:11

I will look into it soon-ish, but presumably, commenting out (or removing) the use-jemalloc line should do it. Thanks for the notice.

ishitatsuyuki commented on 2019-10-21 06:32

I'm not maintaining this package at this moment. If you want to contribute a PKGBUILD, let me know.

theYinYeti commented on 2019-10-20 18:35

Build fails in rust:

failed to parse TOML configuration 'config.toml': unknown field `use-jemalloc`, expected one of `optimize`, `codegen-units`, `codegen-units-std`, `debug-assertions`, `debuginfo-level`, `debuginfo-level-rustc`, `debuginfo-level-std`, `debuginfo-level-tools`, `debuginfo-level-tests`, `parallel-compiler`, `backtrace`, `default-linker`, `channel`, `musl-root`, `rpath`, `optimize-tests`, `codegen-tests`, `ignore-git`, `debug`, `dist-src`, `verbose-tests`, `incremental`, `save-toolstates`, `codegen-backends`, `codegen-backends-dir`, `lld`, `lldb`, `llvm-tools`, `deny-warnings`, `backtrace-on-ice`, `verify-llvm-ir`, `remap-debuginfo`, `jemalloc`, `test-compare-mode`, `llvm-libunwind` for key `rust` at line 356 column 1
failed to run: /home/ME/.cache/yay/rust-git/src/rust/build/bootstrap/debug/bootstrap dist

ishitatsuyuki commented on 2017-10-09 04:21

The build failure is known. Basically https://github.com/rust-lang/rust/issues/44421. Downgrade your glibc if you really want to build.

haawda commented on 2017-10-08 15:32

Fails to build for me: See http://dpaste.com/15FW5ZW

ishitatsuyuki commented on 2017-07-23 02:50

I have disabled the pkgver hack.

SolarAquarion commented on 2017-07-20 14:48

cargo-git-0.21.0.r4496.f709c35a.rust.1.20.0.r65762.9d54ebe550-1-x86_64.pkg.tar.xz
PKGBUILD
rls-git-0.1.0.r534.618f802.rust.1.20.0.r65762.9d54ebe550-1-x86_64.pkg.tar.xz
rust
rust-analysis-git-1.20.0.r65762.9d54ebe550-1-x86_64.pkg.tar.xz
rust-docs-git-1.20.0.r65762.9d54ebe550-1-any.pkg.tar.xz
rust-git-1.20.0.r65762.9d54ebe550-1-x86_64.pkg.tar.xz
rust-src-git-1.20.0.r65762.9d54ebe550-1-any.pkg.tar.xz

Not all the pkgver's are "1.20"

SolarAquarion commented on 2017-07-20 13:55

@ishitatsuyuki shouldn't it be possible to set llvm to 4.0 or earlier and then remove the epoch? Because isn't that why the epoch is there or not?