Package Base Details: roccat-tools

Git Clone URL: https://aur.archlinux.org/roccat-tools.git (read-only, click to copy)
Keywords: gui hardware keyboard mouse settings
Submitter: russo79
Maintainer: aaronfischer
Last Packager: aaronfischer
Votes: 56
Popularity: 0.23
First Submitted: 2012-03-05 16:53
Last Updated: 2020-09-23 21:17

Pinned Comments

aaronfischer commented on 2019-03-28 20:13

@Gonzo2028: See here: https://www.reddit.com/r/linux_gaming/comments/5js1l2/im_stefan_achatz_stopping_programming_linux/

Stunts commented on 2017-01-05 13:13

@gonzo2028:
There are 2 alternative ways:
1. @aaronfischer splits the package into 25 different ones and whenever there is an update he will have to update 25 individual packages; good for the useres, not so good for the maintainer.
2. @aaronfischer "merges" all the files from the split packages into a single package. This will result in installing binaries, udev rules and .desktop files for 25 devices for every user. Less work for the maintainer, not practical for the users.

As is it, the maintainer maintains one single "split-package" and users that use an AUR helper such as yaourt, can uninstall the packages they don't need. This way users get to keep only the files they need to support their own device and the maintainer does not have to modify and commit 25 packages every time there is an update.

Hope this helps clear it.

aaronfischer commented on 2015-11-22 13:21

@edward_81: Please read the previous comments here. I've talked to Stefan about this. Every version of roccat-tools need a specific version of libgaminggear to work correctly. There are two options here: Consistent/reliable package and a little bit of hasle on upgrades -- or easy upgrade process and the chance of a broken package with weird bugs everywhere. I've choosen the first option.

edward_81 commented on 2015-10-03 15:31

Is possible to change the dependency line for libgaminggear from:
libgaminggear=0.11.1
to:
libgaminggear>=0.11.1
Because every time i try to upgrade the system with yaourt/aur, it complain that roccat-tool-common need that exactly version of libgaminggear.

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

fettouhi commented on 2015-06-06 12:17

I just bought a Roccat Kone XTD and I can't change the layout on the mouse. For all buttons I see this:

https://sourceforge.net/p/roccat/discussion/989581/thread/e8e2169f/fa96/attachment/15060001.jpg

all options are greyed anybody else have this?

ImNtReal commented on 2015-03-25 18:58

That will work since you're pointing pacman at both files at the same time, but any of the helpers that run the install portion for you do them one at a time. It likely is a behavior that should be changed by the helpers.

Vash63 commented on 2015-03-16 21:46

Cower to download the pkgbuild, makepkg and pacman -U handles this without issue.

ImNtReal commented on 2015-03-16 15:59

I've tried about 10 different AUR helpers, and come to the conclusion that there is no practical way to update this package without removing/reinstalling it. I keep forgetting to modify the PKGBUILD when I build it to include the '>' for libgaminggear so, I have created roccat-tools-full which will be a non-split package which includes the controversial '>'.

ImNtReal commented on 2015-03-16 14:07

@Vash63, are you aware of any AUR helpers that can correctly handle this kind of dependency? Thanks.

Vash63 commented on 2015-03-14 10:33

How is it the packager's fault that your AUR helper can't handle the combined package? Works just fine with cower, makepkg and pacman -U. Maybe you should submit patches to the yaourt devs if it isn't handling this as you would like.

Salamandar commented on 2015-03-14 10:13

Well, I understand there is no retrocompatibility with libgaminggear, but updates are a pain in the ass now :(

And for the split package, I don't understand the reason. Right now everything is a pain in the ass :
× Uninstalling :
$ yaourt -R roccat-tools-common
vérification des dépendances...
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: roccat-tools-arvo : requiert roccat-tools-common
:: roccat-tools-isku : requiert roccat-tools-common
:: roccat-tools-iskufx : requiert roccat-tools-common
:: roccat-tools-kone : requiert roccat-tools-common
:: roccat-tools-koneplus : requiert roccat-tools-common
:: roccat-tools-konepure : requiert roccat-tools-common
:: roccat-tools-konepuremilitary : requiert roccat-tools-common
:: roccat-tools-konepureoptical : requiert roccat-tools-common
:: roccat-tools-konextd : requiert roccat-tools-common
:: roccat-tools-konextdoptical : requiert roccat-tools-common
:: roccat-tools-kovaplus : requiert roccat-tools-common
:: roccat-tools-lua : requiert roccat-tools-common
:: roccat-tools-pyra : requiert roccat-tools-common
:: roccat-tools-ryosmk : requiert roccat-tools-common
:: roccat-tools-ryostkl : requiert roccat-tools-common
:: roccat-tools-savu : requiert roccat-tools-common
:: roccat-tools-tyon : requiert roccat-tools-common
× Update : everything is updated, that's useless !
I really don't understand why not just create "roccat-tools" only !

aaronfischer commented on 2015-03-14 09:53

No, I will not split up the package and no, I will not put a greater sign at the libgaminggear dependency. Please read the comments below, I am sick of explaining stuff 10 times.

Salamandar commented on 2015-03-14 00:19

Hi !
× Please, as all these packaget are in fact the same, could you do only ONE package ? It's completely impossible to update simply the package (it updates ALL packages, i.e 18 times the same…)
roccat-tools-common
roccat-tools-arvo
roccat-tools-isku
roccat-tools-iskufx
roccat-tools-kone
roccat-tools-koneplus
roccat-tools-konepure
roccat-tools-konepuremilitary
roccat-tools-konepureoptical
roccat-tools-konextd
roccat-tools-konextdoptical
roccat-tools-kovaplus
roccat-tools-lua
roccat-tools-pyra
roccat-tools-ryosmk
roccat-tools-ryostkl
roccat-tools-savu
roccat-tools-tyon
× Please, in your dependencies, put "libgaminggear>=0.7.0" and not "=". At each LibGamingGear update, I have to uninstall roccat-tools-common, update the lib, reinstall roccat-tools-common
":: roccat-tools-common : requiert libgaminggear=0.6.0"

It would be far mor simple. Thanks.

pdq commented on 2015-03-02 03:31

Please amend the PKGBUILD to include the added support in 3.1.0 for roccat-tools-ryostkl. Thanks! :]