Package Base Details: python-powerline-git

Git Clone URL: https://aur.archlinux.org/python-powerline-git.git (read-only)
Submitter: Lokaltog
Maintainer: gbs
Last Packager: gbs
Votes: 134
Popularity: 0.000118
First Submitted: 2013-01-23 07:28
Last Updated: 2018-10-10 20:08

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 Next › Last »

Lokaltog commented on 2013-09-27 22:01

Those docs are for another project.

hav3lock commented on 2013-09-26 23:11

Also, this package cannot be installed with Aura, pacaur, or spinach. Please fix this.

hav3lock commented on 2013-09-26 23:11

Also, this package cannot be installed with Aura, pacaur, or spinach. Please fix this.

hav3lock commented on 2013-09-26 23:07

Please add the vim documentation to the package, you can get it here:

https://github.com/Lokaltog/vim-powerline/blob/develop/doc/Powerline.txt

hav3lock commented on 2013-09-26 23:00

Please add the vim documentation to the package, you can get it here:

https://github.com/Lokaltog/vim-powerline/blob/develop/doc/Powerline.txt

jck commented on 2013-09-16 23:59

distribute needs to be replaced by setuptools

Anonymous comment on 2013-09-11 12:52

After the latest update I keep having this error

chown: cannot access '/var/cache/pacman/pkg/python2-powerline-git20032/python2-powerline-git': No such file or directory

Lokaltog commented on 2013-08-27 07:45

Ah, I see. Anyways, as a temporary workaround you can delete /usr/share/vim/vimfiles/plugin/powerline.vim to disable Powerline globally.

uberben commented on 2013-08-26 15:51

I've been trying out the spf13 vim configuration, which aims to be pretty independent (ie. no external dependencies on things like python) and so it uses airline instead of powerline. I've used both and they are both great, but I like the portability of a viml version.

This is the error I get when powerline for vim is enabled (I'm running python 3.3.2):

An error occurred while importing the Powerline package. This could be caused by an invalid sys.path setting, or by an incompatible Python version (Powerline requires Python 2.6+ or 3.2+ to work). Please consult the troubleshooting section in the documentation for possible solutions.
Press ENTER or type command to continue

Lokaltog commented on 2013-08-23 16:16

Hm, I didn't really think about that. I'll see what I can do. Is there a particular reason why you want to use Powerline for tmux, but not in vim? Also, what kind of error do you get when using Powerline and airline together?