Package Base Details: python-kivy-git

Git Clone URL: https://aur.archlinux.org/python-kivy-git.git (read-only, click to copy)
Submitter: haagch
Maintainer: None
Last Packager: NicoHood
Votes: 18
Popularity: 0.000000
First Submitted: 2015-06-16 15:50
Last Updated: 2017-05-09 11:58

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

mixedCase commented on 2016-11-08 19:06

@NicoHood This packages dependencies' have been updated to allow Kivy to build with the recommended SDL2 backends instead of the pygame ones.

I inherited this package and simply fix it when it breaks, other packages seem to be broken more often than not (at least when I try them).

If I understood it correctly, your proposed package builds both Python 3 and Python 2 packages, inconsistent with the rest of the Arch ecosystem. I don't mind sharing more code, specially when that helps get all packages in a consistent condition, but that's a deal breaker.

Btw, what does setting LC_CTYPE achieve in this case?

haagch commented on 2016-11-08 19:01

@NickHood
I did just orphan it and you can adopt it or request its deletion, whatever you like.

The reason this is different is probably because back in the day this was the only way that worked for me. The only reason I made this package in the first place is because kivy wasn't officially released for python3 yet.

NicoHood commented on 2016-11-08 18:57

@haagch I'd like to merge this with the python2 version of this package:
https://aur.archlinux.org/packages/python2-kivy-git/

Your PKGBUILD, the python2-git PKGBUILD and the official one differs a lot in the build process and also for the dependencies. Could you give us any reasons why you do something different than other packages?

This is my current package suggestion:
https://gist.github.com/NicoHood/f76dbf1ef51b43afd9881a8b39f0edb4

Please give me feedback and also let me know who of you two want to maintain the package now. I can also co-maintain it if desired, or at least push the fix described above.

NicoHood commented on 2016-11-08 18:57

@mixedCase I'd like to merge this with the python3 version of this package:
https://aur.archlinux.org/packages/python-kivy-git/

Your PKGBUILD, the python3-git PKGBUILD and the official one differs a lot in the build process and also for the dependencies. Could you give us any reasons why you do something different than other packages?

This is my current package suggestion:
https://gist.github.com/NicoHood/f76dbf1ef51b43afd9881a8b39f0edb4

Please give me feedback and also let me know who of you two want to maintain the package now. I can also co-maintain it if desired, or at least push the fix described above.

haagch commented on 2015-12-18 15:35

Ah, finally I've had another look at this. The build works now again and there is finally a python-pygame package.

yan12125 commented on 2015-11-20 11:19

And now python-pygame-hg is gone. Builds can't go without modifying PKGBUILD.

yumaokao commented on 2015-10-21 03:14

I could make it compiled with s/python-pygame-hg/python-pygame/

ngoonee commented on 2015-10-14 20:15

The last sed line raises an error with current master. I don't think it's needed anyway, I've never seen /usr/bin/env python or similar in any of the kivy source files I've happened to have to edit.

mixedCase commented on 2015-05-19 02:41

It's a git package of actively developed software. I could remove the commit hash from the package versions and it would remove the warning but it would also remove useful information, since you want to know exactly what you're running your software against.

I'm afraid the ABS does not provide any way (that I know of, please correct me if my knowledge is out of date) to solve this problem for -git AUR packages, so what we have is the best way.

D_Schwartfeger commented on 2015-05-19 02:34

Could you fix the version info?

I have just installed but octopi says-
Version 1:1.9.0.6186fa0-1 (outdated installed version is 1:1.9.0.183.ga6ea61b-1)