Package Base Details: php70

Git Clone URL: https://aur.archlinux.org/php70.git (read-only, click to copy)
Submitter: betrixed
Maintainer: wget
Last Packager: wget
Votes: 10
Popularity: 0.000000
First Submitted: 2017-02-05 08:12
Last Updated: 2019-04-28 22:32

Pinned Comments

wget commented on 2018-04-24 22:41

This package makes use of GPG keys for integrity verification. Here are the PGP keys you need to import (if you trust them):

$ gpg --recv-keys 1A4E8B7277C42E53DBA9C7B9BCAA30EA9C0D5763 6E4F6AB321FDC07F2C332E3AC2BF0BC433CFC8B3

Receiving GPG keys might fail with the following error message: $ gpg: keyserver receive failed: Connection refused. If this happens, just check your DNS or use other ones.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

betrixed commented on 2017-07-25 02:27

I incorporated the corrections suggested earlier. Sorry not checking for them often enough.

This package won't pass PGP check unless the first key in the validpgpkeys array for Anatol Belski <ab@php.net> is added to the local key-ring. See comment near validpgpkeys

This command line works on my setup.

gpg --recv-keys 1A4E8B7277C42E53DBA9C7B9BCAA30EA9C0D5763

I don't know how to make the package auto magically work for everybody, by having the package ensure the key is imported before the validity check.
I think the validpgpkeys get checked before the call to prepare(), and therefore no way I can put key addition in the package.

I also do not know how new pgp keys such as above, get proposed to put in the pacman key-ring, for use of AUR builds by makepkg.

enginefeeder101 commented on 2017-06-24 10:00

There is an error in PKGBUILD line 191. Due to the single quotes the php.ini file is NOT BACKED UP, your configuration will be LOST!

--- PKGBUILD 2017-06-24 11:41:32.769813893 +0200
+++ PKGBUILD 2017-06-24 11:56:25.114753127 +0200
@@ -188,7 +188,7 @@
replaces=('php70-ldap')
conflicts=('php70-ldap')
provides=("${_pkgbase}=$pkgver")
- backup=('etc/${pkgbase}/php.ini')
+ backup=("etc/${pkgbase}/php.ini")

cd ${srcdir}/build
make -j1 INSTALL_ROOT=${pkgdir} install-{modules,cli,build,headers,programs,pharcmd}

aeno commented on 2017-05-16 13:47

PKGBUILD line 271 should read:

install -D -m644 ${srcdir}/php-fpm.tmpfiles ${pkgdir}/usr/lib/tmpfiles.d/${pkgbase}-fpm.conf

currently, there's a /../ after the srcDir

rhssk commented on 2017-05-15 15:07

backup=('etc/${pkgbase}/php.ini') (from quick glance this seems like the only problematic line) needs to be enclosed in double quotes instead of single as the pkgbase variable is parsed as plain string.
The unintended result can be seen in pacman -Qii php70
backup line and results in a complete php.ini overwrite.

pipo1000 commented on 2017-05-11 07:37

I have installed the openssl-1.0 package like in the AUR php56 package. However a previous build php 7.0-17 with a installed openss-1.0 and openssl-1.1 lib bombs out with segmentation fault even on a php_info(). Without changes php70 does not build with 1.1 installed. I have tried the PKG_CONFIG_PATH and now it builds again but I did not try it yet as this server this business critical and I first have to setup a test server to make sure it does not fails with segmentation errors.

At this time I have moved back to AUR/php56 which seems to run fine.

lilmike commented on 2017-05-02 13:53

When looking at the php56 package, which does detect openssl-1.0 correctly, I noticed before the ./configure etc steps:

export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig

This (seems to have) done the trick. Perhaps this could be tested and incorporated into the package if it works?
-Michael.

stef.an commented on 2017-04-27 14:37

openssl-1.0 installs in a way PHP doesn't detect.

Here's my (dirty) way to compile it anyway:

1. install openssl-1.0
2. mkdir -p /opt/openssl-1.0/include
3. ln -s /usr/lib/openssl-1.0/ /opt/openssl-1.0/lib
4. ln -s /usr/include/openssl-1.0/openssl/ /opt/openssl-1.0/include/openssl

5. edit PKGBUILD, change
--with-openssl
to
--with-openssl=/opt/openssl-1.0

VVL commented on 2017-04-25 14:59

After upgrading OpenSSL to 1.1.0 gives error:
"configure: error: OpenSSL version >= 1.1 is not supported."
even if openssl-1.0 installed. Cant find it at PKGBUILD to fix manually.
On php.net seems php support openssl 1.1.0. What ways make it work? :)

eschwartz commented on 2017-04-20 08:49

After someone asked about this in the #archlinux IRC channel, I looked at this PKGBUILD, and you really need to add the validpgpkeys array back.

I don't know why you thought it should be removed in the first place, because now everyone *definitely* has problems since makepkg tries to verify the PGP signature but doesn't recognize the key!

...

gpg --verify warned you that the key has not been marked as a trusted key, but this is not actually problematic in any way, since makepkg and gpg are two entirely different things... see the wiki for more details: https://wiki.archlinux.org/index.php/PKGBUILD#validpgpkeys

Particularly the part about "[makepkg] will ignore the trust values from the keyring".

cutgah commented on 2017-04-20 08:44

From the #archlinux IRC:

The maintainer should put that array back where it came from [the validpgpkeys array] because the whole point of that array is to tell makepkg that the named key is trusted, but manually running gpg --verify does not have the same trust.