Package Base Details: php70

Git Clone URL: https://aur.archlinux.org/php70.git (read-only, click to copy)
Submitter: betrixed
Maintainer: wget
Last Packager: wget
Votes: 10
Popularity: 0.001199
First Submitted: 2017-02-05 08:12
Last Updated: 2019-04-28 22:32

Pinned Comments

wget commented on 2018-04-24 22:41

This package makes use of GPG keys for integrity verification. Here are the PGP keys you need to import (if you trust them):

$ gpg --recv-keys 1A4E8B7277C42E53DBA9C7B9BCAA30EA9C0D5763 6E4F6AB321FDC07F2C332E3AC2BF0BC433CFC8B3

Receiving GPG keys might fail with the following error message: $ gpg: keyserver receive failed: Connection refused. If this happens, just check your DNS or use other ones.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

lilmike commented on 2018-03-12 08:28

Hi all, I've just created a php71 package that doesn't conflict with php 7.2 (or any other php version to my knowledge). It's called php71-noconflict (and php71-[...]-noconflict). Let me know if you have any feedback. Hope people find it useful! -Michael.

wget commented on 2018-03-09 10:51

Package upgraded to 7.0.28: https://github.com/wget/archlinux-aur-php70

elimpfor commented on 2018-02-06 15:17

This is broken without the patch by @wget.

wget commented on 2018-02-01 11:54

Hello everyone. Could someone merge this commit in this package? https://github.com/wget/archlinux-aur-php70/commit/13d6560cdb713e842de659d7e811678f51265a1b Otherwise, without this enchant 2 fix, php 7.0 cannot be built on Arch Linux. Thanks a lot :)

broiniac commented on 2018-01-18 11:14

@Varakh: php7.1 for some reason is available in Community repo for 9 days now: https://www.archlinux.org/packages/community/x86_64/php71/ Unfortunately it is in conflict with regular (up-to-date) php (v7.2).

+1 though to your request - having nice, non conflicting 7.1 version would be nice.

I did tried to compile it by myself using same pkbuild as this package doing proper source and checksum changes, but I've failed. Epicly.

Varakh commented on 2018-01-09 09:11

@betrixed: Thanks for maintaining the package, very useful as PHP 7.2 breaks several old applications. Do you plan to provide a PHP 7.1 package aswell? This would be very nice. I already tried building it myself using old PKGBUILD files of the official repository, but I didn't get it running.

rio commented on 2017-12-25 06:56

I guess in all packages we should just have provides directives with ${pkgbase} replaced by ${_pkgbase} since no package should have dependencies on php70-foo anyway. Note that the current PKGBUILD already does this for php-cgi.

Raansu commented on 2017-12-23 08:34

Manually applying the fix mentioned by @teekay fixes the issue for me and Nextcloud installs without issue.

Raansu commented on 2017-12-23 07:30

Even though I have this package installed I get an error trying to install Nextcloud, something needs to be fixed.

[kumo@kumo ~]$ sudo pacman -S nextcloud
resolving dependencies...
warning: cannot resolve "php-gd<7.2", a dependency of "nextcloud"
:: The following package cannot be upgraded due to unresolvable dependencies:
      nextcloud

teekay commented on 2017-12-11 13:22

I second @aexoxea's and @z3ntu's comments regarding provides for the split packages.

For example php70-gd with

provides=("${pkgbase}-gd=$pkgver" "${_pkgbase}-gd=$pkgver")

would make nextcloud-12.x happy (which requires php-gd<7.2)