Package Base Details: php56

Git Clone URL: (read-only, click to copy)
Keywords: php
Submitter: mickael9
Maintainer: matth
Last Packager: foxxx0
Votes: 47
Popularity: 0.000004
First Submitted: 2016-01-03 21:26
Last Updated: 2019-01-15 09:12

Pinned Comments

mickael9 commented on 2018-10-03 17:21

PHP 5.6 will stop getting security updates in January 2019. Consider upgrading to PHP 7 now

mickael9 commented on 2016-04-06 11:51

PLEASE READ : For those who are getting "unknown public key" errors, this is NOT caused by this package. It means GPG is not configured to fetch public keys automatically (which is normal by default)

Please read the instructions at

The easiest way to overcome this is to manually import the keys from a keyserver :

$ gpg --keyserver hkp:// --recv-keys C2BF0BC433CFC8B3 FE857D9A90D90EC1

mickael9 commented on 2016-01-14 01:53

foxxx and I have been working together and this package can now be installed along PHP 7 from the official repos.

Everything has been moved into separate directories :

Config : /etc/php56
Extensions : /usr/lib/php56/modules
Binaries : /usr/bin/php56, /usr/bin/php56-cgi, /usr/bin/phar56, etc.

If you were previously using this as a replacement for php7, you'll have to adjust the new configuration files in /etc/php56/ to reflect the current ones in /etc/php/.

Apache module (provided by php56-apache) also has a specific configuration and CAN NOT cohabit with php7_module. Use php-fpm, fcgi or cgi if you need both versions.

The apache module is installed as, so you should use the following lines your httpd.conf :

# Load php 5.6 module
LoadModule php5_module modules/

# Use it for .php extensions
Include conf/extra/php56_module.conf

Please let me know if you encounter any problem or have a suggestion.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

polarbear commented on 2018-02-23 22:55

If you have problems with the enchant just install "enchant-pure" with aur :)

loscsol commented on 2018-02-05 09:55

Nice work @Schmeidenbacher, patch works fine.

For the others, just save it locally and add this in PKGBUILD's prepare():

patch -p0 -l -i ${srcdir}/../php56-configure.patch

Like this:

prepare() {
        cd ${srcdir}/${_pkgbase}-${pkgver}

        patch -p0 -i ${srcdir}/php.ini.patch
        patch -p0 -i ${srcdir}/
        patch -p0 -l -i ${srcdir}/../php56-configure.patch
        # Just because our Apache 2.4 is configured with a threaded MPM by default does not mean we want to build a ZTS PHP.
        # Let's supress this behaviour and build a SAPI that works fine with the prefork MPM.
        sed '/APACHE_THREADED_MPM=/d' -i sapi/apache2handler/config.m4 -i configure

        # Allow php-tidy to compile with tidy-html5
        sed 's/buffio\.h/tidybuffio\.h/' -i ext/tidy/tidy.c

Schmeidenbacher commented on 2018-02-03 12:56

My previous (and now deleted) comment was not quite complete.

A test build revealed a flaw in the patch. This version builds with the newest enchant version:

Fell free to use it in this package.

drankinatty commented on 2018-02-03 09:07

Why does php56 not build with enchant version 2.2.1-1 installed? All prior versions of php56 had had no problems with the package. Yes, I can grab enchant-pure from AUR and build, but I shouldn't have to uninstall a standard package just to get php56 to build. Has the problem been identified? I'll patch with enchant-pure this go-round, but will need to reinstall the Arch package.

tjbp commented on 2018-02-01 23:55

The package enchant-pure contains the necessary symlinks for this to compile again. If the enchant maintainer isn't interested in adding the symlinks it might be worth switching the dependency accordingly.

jdccdevel commented on 2018-01-31 22:34

php56 version 5.6.33-1 will not build if enchant version 2.2.1-1 is installed.

It appears the headers for that version of enchant are installed in /usr/include/enchant-2 instead of /usr/include/enchant as the php56 configure script is expecting.

The PHP7 build has a patch for the configure script that may be relevant.

foxxx0 commented on 2018-01-17 09:18


To me it looks like php71 is causing this as it explicitly conflicts with "php". Due to the fact that the php56 packages have a provide="php" in order to be used as deps for packages that require "php", there is no way to fix this from within php56.

You can either rebuild the php71 packages yourself so that they do not conflict with "php" in order to install php71 and php56 alongside each other or simply wait until all your php 7 applications are compatible with php 7.2 and then leave out the php71 packages.

Please also note that php 5.6 support will end this year (31st December 2018) and there are no security updates after that. I strongly encourage everyone using php 5.6 to start looking for application updates or alternatives over the course of this year.

marlemion commented on 2018-01-17 09:08

I have nextcloud running alongside with web service in need of php56. Until recently, I managed this with two parallel php installations (plain php from pacman and php56 via AUR). Now, nextcloud needs php71, while the main version alrady went up to 7.2. Apparently, a php71 package was created to deal with this requirement. However, it breaks parallel installation with php56:

pacman -Suy :: Synchronizing package databases... core is up to date extra is up to date community is up to date multilib is up to date repo-ck is up to date :: Starting full system upgrade... resolving dependencies... looking for conflicting packages... warning: removing 'php' from target list because it conflicts with 'php71' warning: removing 'php-gd' from target list because it conflicts with 'php71-gd' :: php71 and php are in conflict. Remove php? [y/N] y :: php71 and php56 are in conflict (php). Remove php56? [y/N] y :: php71-gd and php-gd are in conflict. Remove php-gd? [y/N] y :: php71-gd and php56-gd are in conflict (php-gd). Remove php56-gd? [y/N] y error: failed to prepare transaction (could not satisfy dependencies) :: php56-apache: removing php56 breaks dependency 'php56' :: php56-cgi: removing php56 breaks dependency 'php56' :: php56-dblib: removing php56 breaks dependency 'php56' :: php56-embed: removing php56 breaks dependency 'php56' :: php56-enchant: removing php56 breaks dependency 'php56' :: php56-fpm: removing php56 breaks dependency 'php56' :: php56-imap: removing php56 breaks dependency 'php56' :: php56-intl: removing php56 breaks dependency 'php56' :: php56-ldap: removing php56 breaks dependency 'php56' :: php56-mcrypt: removing php56 breaks dependency 'php56' :: php56-mssql: removing php56 breaks dependency 'php56' :: php56-odbc: removing php56 breaks dependency 'php56' :: php56-pear: removing php56 breaks dependency 'php56' :: php56-pgsql: removing php56 breaks dependency 'php56' :: php56-phpdbg: removing php56 breaks dependency 'php56' :: php56-pspell: removing php56 breaks dependency 'php56' :: php56-snmp: removing php56 breaks dependency 'php56' :: php56-sqlite: removing php56 breaks dependency 'php56' :: php56-tidy: removing php56 breaks dependency 'php56' :: php56-xsl: removing php56 breaks dependency 'php56'

Additional info: package version(s) config and/or log files etc.

Maybe you are already aware of this. For now, this is a showstopper for me. I have to wait for nextcloud 13. Before release, I will not be able to update the system anymore... :/

foxxx0 commented on 2018-01-12 13:54

Updated to 5.6.33:

The PHP development team announces the immediate availability of PHP 5.6.33. This is a security release. Several security bugs were fixed in this release. All PHP 5.6 users are encouraged to upgrade to this version.

drankinatty commented on 2017-12-06 20:52

update to 5.32 (and Pierre finally making the pkgrel bump to -2 in php 7.2.0-2) allowed php 7.2 to install without php56-mcrypt removal conflict, httpd now runs again (and virtualbox drivers now build again after Linux 4.14 install -- with forced update to vbox 5.2.2, 5.1.30 modules do not build) 4.14 was not a smooth jump...