Package Base Details: php56

Git Clone URL: https://aur.archlinux.org/php56.git (read-only)
Keywords: php
Submitter: mickael9
Maintainer: mickael9 (foxxx0)
Last Packager: foxxx0
Votes: 47
Popularity: 0.002307
First Submitted: 2016-01-03 21:26
Last Updated: 2019-01-15 09:12

Pinned Comments

mickael9 commented on 2018-10-03 17:21

PHP 5.6 will stop getting security updates in January 2019. Consider upgrading to PHP 7 now

mickael9 commented on 2016-04-06 11:51

PLEASE READ : For those who are getting "unknown public key" errors, this is NOT caused by this package. It means GPG is not configured to fetch public keys automatically (which is normal by default)

Please read the instructions at https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

The easiest way to overcome this is to manually import the keys from a keyserver :

$ gpg --keyserver hkp://hkps.pool.sks-keyservers.net:80 --recv-keys C2BF0BC433CFC8B3 FE857D9A90D90EC1

mickael9 commented on 2016-01-14 01:53

foxxx and I have been working together and this package can now be installed along PHP 7 from the official repos.

Everything has been moved into separate directories :

Config : /etc/php56
Extensions : /usr/lib/php56/modules
Binaries : /usr/bin/php56, /usr/bin/php56-cgi, /usr/bin/phar56, etc.

If you were previously using this as a replacement for php7, you'll have to adjust the new configuration files in /etc/php56/ to reflect the current ones in /etc/php/.

Apache module (provided by php56-apache) also has a specific configuration and CAN NOT cohabit with php7_module. Use php-fpm, fcgi or cgi if you need both versions.

The apache module is installed as libphp56.so, so you should use the following lines your httpd.conf :

# Load php 5.6 module
LoadModule php5_module modules/libphp56.so

# Use it for .php extensions
Include conf/extra/php56_module.conf

Please let me know if you encounter any problem or have a suggestion.

Latest Comments

« First ‹ Previous ... 12 13 14 15 16 17

mickael9 commented on 2016-01-06 16:40

@Hoek : it should work if you install both packages at the same time so that the resulting transaction does not introduce any conflicts

dcelasun commented on 2016-01-05 11:25

@mickael9: OK then, I can probably set up an x64 repo for php56* over the weekend.

Hoek commented on 2016-01-05 11:24

@mickael9: Thanks for the effort. I have php7 installed and try to revert to php56, maybe they should be flagged exclusive?


When trying to install php56-apache:

-> Saved package: php56-apache-5.6.16-2-x86_64.pkg.tar.xz
[sudo] password for hoek:
loading packages...
resolving dependencies...
warning: cannot resolve "php56", a dependency of "php56-apache"
:: The following package cannot be upgraded due to unresolvable dependencies:
php56-apache

:: Do you want to skip the above package for this upgrade? [y/N] N
error: failed to prepare transaction (could not satisfy dependencies)
:: php56-apache: requires php56

mickael9 commented on 2016-01-04 17:04

Thanks for the feedback but I was unable to reproduce the "duplicate target" errors and the download/integrity errors.

I updated the PKGBUILD with more strict dependency checking and removed the "www." prefix from the source URLs. We'll see if this works better.

As for the binary repos, I don't provide any, but anyone is free to do so. Note that PHP only takes a few minutes to compile on my laptop.

bruddy commented on 2016-01-04 10:47

Thanks for the package, it saved a lot of time. I ran into the same issue and try to remove the sub domain as marcvangend suggested (the GPG signature check failed of course and i didn't go any further).

Instead, I used another mirror listed there : http://php.net/get/php-5.6.16.tar.xz/from/a/mirror. GPG check went well as well as the whole installation (just had to force pacman to not check upon some dependencies)

Having said that, I don't know if the installation issue is related. For the conflicting packages, pacman should warn you and ask which one to keep.

marcvangend commented on 2016-01-04 10:33

@Hoek I got the same errors. Maybe the problem is that the PKGBUILD declares all sub-packages of php56 as conflicting, for example: "conflicts=('php-fpm')".

Hoek commented on 2016-01-04 09:46

Trying to install with marcvangend's hint (fix the upstream source), after the compilation finishes, i get the following error:

==> Finished making: php56 5.6.16-1 (Mon 4 Jan 10:41:09 CET 2016)
[sudo] password for hoek:
loading packages...
error: 'php56-cgi-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-apache-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-fpm-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-embed-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-phpdbg-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-pear-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-enchant-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-gd-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-imap-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-intl-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-ldap-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-mcrypt-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-mssql-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-odbc-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-pgsql-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-pspell-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-snmp-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-sqlite-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-tidy-5.6.16-1-x86_64.pkg.tar.xz': duplicate target
error: 'php56-xsl-5.6.16-1-x86_64.pkg.tar.xz': duplicate target

Any suggestions what could cause them?

marcvangend commented on 2016-01-04 08:32

The upstream resources don't seem to exist (at the moment): "==> ERROR: Failure while downloading php-5.6.16.tar.xz". When you change "http://www.php.net/distributions/php-5.6.16.tar.xz" to "http://php.net/distributions/php-5.6.16.tar.xz" (remove the www subdomain) the download does succeed, but the integrity check fails with "php-5.6.16.tar.xz ... FAILED (unknown public key C2BF0BC433CFC8B3)".

I managed to build the package using packer with the --skipinteg option, but that's not recommended of course. Once the build was complete, installation failed with "error: 'php56-***-5.6.16-1-x86_64.pkg.tar.xz': duplicate target". Help / fixes/ documentation is appreciated.

dcelasun commented on 2016-01-04 07:49

Thanks for this package. Is there a binary repo available somewhere?