Package Base Details: oss-nonfree

Git Clone URL: https://aur.archlinux.org/oss-nonfree.git (read-only, click to copy)
Keywords: oss
Submitter: alexdw
Maintainer: alexdw
Last Packager: alexdw
Votes: 15
Popularity: 0.000661
First Submitted: 2013-06-23 13:17
Last Updated: 2020-12-29 17:36

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

talonz commented on 2013-08-18 22:26

yeah the ossvermagic fix by DrQwertySilence is a blessing no my mpd daemon starts automatically thanks
and thanks for the update alexdw

alexdw commented on 2013-08-17 00:05

Updated (4.2_2008-6) with the patch klothius linked to below found on the OSS forums: http://www.opensound.com/forum/viewtopic.php?f=3&t=5275
This seems to fix the issue with 3.10.7 (at least in my VirtualBox install).

Also amended soundon to not use ossvermagic as described by DrQwertySilence (thanks!). This might cause issues if you're using old (i.e. 2.6 or earlier) kernel versions but I've left the replaced line as a comment so it's an easy modification if required. In 3.10.6 and 3.10.7 this has significantly increased the speed of soundon (from around a couple of minutes to less than a couple of seconds).

alexdw commented on 2013-08-17 00:04

Updated (4.2_2008-6) with the patch klothius linked to below found on the OSS forums: http://www.opensound.com/forum/viewtopic.php?f=3&t=5275
This seems to fix the issue with 3.10.7 (at least in my VirtualBox install).

Also amended soundon to not use ossvermagic as described by DrQwertySilence. This might cause issues if you're using old (i.e. 2.6 or earlier) kernel versions but I've left the replaced line as a comment so it's an easy modification if required. In 3.10.6 and 3.10.7 this has significantly increased the speed of soundon (from around a couple of minutes to less than a couple of seconds).

alexdw commented on 2013-08-16 23:42

Updated (4.2_2008-6) with the patch klothius linked to below found on the OSS forums: http://www.opensound.com/forum/viewtopic.php?f=3&t=5275
This seems to fix the issue with 3.10.7 (at least in my VirtualBox install).

Also tried to amend soundon to not use ossvermagic as described by DrQwertySilence for kernels above 2.6.35. Not sure if this has worked though as I don't notice much difference - soundon still takes around a couple of minutes (however again I only tested it in VirtualBox).

talonz commented on 2013-08-16 01:42

i think the latest kernel update broke oss again
3.10.7-1-ARCH

sudo soundon
modprobe: ERROR: could not insert 'osscore': Exec format error
Loading the osscore module failed

Anonymous comment on 2013-08-09 03:04

If 'soundon' is taking more time that the normal (like 20s instead of 0.2s) to run oss, is the fault of 'ossvermagic', this return nothing and take 20s to do this.

Replace:
KERNEL_VERMAGIC=`/usr/bin/ossvermagic -z -s`
With:
KERNEL_VERMAGIC="" <- or whatever ossvermagic is returning

alexdw commented on 2013-07-29 22:25

Yeah, I saw this, thanks for reminding me about it. As far as I can tell though, 3.11 is not yet in the Testing repo - I'll have a look at using the patch to fix this once it is.

klothius commented on 2013-07-28 22:36

Well 3.11 brings another breakage, but luckily it seems there's already a patch on oss forums -> http://www.opensound.com/forum/viewtopic.php?f=3&t=5275

klothius commented on 2013-07-28 22:35

Well 3.11 brings another breakage, but luckily it seems there's already a patch on oss forums -> http://www.opensound.com/forum/viewtopic.php?f=3&t=5275&sid=cc6fdd8bc365469723b53104424f6700

alexdw commented on 2013-07-06 13:50

Updated with the 3.10 kernel patch found on the OSS forums: http://www.opensound.com/forum/viewtopic.php?f=3&t=5247

Tested and working for me with both the (x86_64) 3.10 kernel in the Testing repo and the 3.9.9 kernel in Core.