Package Base Details: oss-git

Git Clone URL: https://aur.archlinux.org/oss-git.git (read-only)
Keywords: oss
Submitter: Nowaker
Maintainer: Galaxy
Last Packager: Galaxy
Votes: 22
Popularity: 0.014553
First Submitted: 2013-09-21 13:15
Last Updated: 2019-11-01 17:19

Pinned Comments

Galaxy commented on 2019-10-24 02:55

The latest support Intel HDA is 0x8c20, and I am using a348. If your sound card is not listed there, it is not supported.

  • 8c20 ("8 Series/C220 Series Chipset High Definition Audio Controller")
  • a348 ("Cannon Lake PCH cAVS")

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 Next › Last »

alexdw commented on 2015-05-31 09:52

@ruegerjr: Thanks - that makes sense as oss-nonfree (precompiled) hasn't been broken by kernel 4.0.4.

ruegerjr commented on 2015-05-31 00:24

Problem this time is NOT the kernel. It is the recent upgrade of gcc. Package still builds for kernel 4.04 if gcc is downgraded from 5.1.0-4 to 4.9.2-4.

alexdw commented on 2015-05-27 21:46

@vaultex: Thanks for the report. I just tried and get the same error on linux 4.0.4. If I have some time over the weekend I'll see if I can work out a patch for it.

vaultex commented on 2015-05-27 09:55

Hi there, just installed latest Arch Linux, still cannot get Oss to install properly with latest patched version

../../make.defs:11: recipe for target 'subdirs' failed
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory '/home/archie2/oss-git/src/oss/build/kernel/drv'
../make.defs:11: recipe for target 'subdirs' failed
make[1]: *** [subdirs] Error 1
make[1]: Leaving directory '/home/archie2/oss-git/src/oss/build/kernel'
make.defs:11: recipe for target 'subdirs' failed
make: *** [subdirs] Error 1
==> ERRO: Uma falha ocorreu em build().
A cancelar...

Is there anything I can do to solve this,
Im new to Arch and to linux in general...

Thank you!

alexdw commented on 2015-05-07 19:35

Updated with patch for Linux kernel 4.0 by "oss117" from the OSS forums - thanks again ruegerjr for the link.

alexdw commented on 2015-05-06 06:38

@dinux, @ruegerjr: Thanks for the information. I'll have a look at fixing this package by the end of the day.

ruegerjr commented on 2015-05-01 21:45

A patch exists courtesy of "oss117" at
http://www.4front-tech.com/forum/viewtopic.php?t=5800&p=21140
which should solve the breakage with linux kernal 4.0+, but as currently written would need to be run patch -p2 from "..src/oss/setup", or patch -p1 from "..src/oss", not from directory "..src/oss/setup/Linux" as with other patches in the PKGBUILD. I assume it should work for oss-nonfree and oss as well?

dinux commented on 2015-05-01 13:43

after last system update to Linux dinux 4.0.1-1-ARCH #1 SMP PREEMPT Wed Apr 29 12:00:26 CEST 2015 x86_64 GNU/Linux

getting this error

for n in *.c; do ../../../ossmkdep -M -I../../../include -I../../../kernel/framework/include -I../../../kernel/OS/Linux -I../../../kernel/nonfree/include -I../../.. $n | sed 's/\(.*\)\.o:/$(DEPDIR)\/\1.o:/' >> .depend; done
make[1]: Leaving directory '/tmp/yaourt-tmp-dinux/aur-oss-git/src/oss/build/kernel/OS/Linux'
Directory preparation complete.
Build ID will be 2011
make: *** No rule to make target 'build'.

alexdw commented on 2015-04-25 15:05

I have removed the out of date flag from 2015-04-20 as the package seems to work for me and gets the git source so not sure why/how it would be out of date.

alexdw commented on 2015-03-01 23:51

Updated (ac48ed-1) for build 2011 (to match oss and oss-nonfree).