Package Base Details: nvidia-full-beta-all

Git Clone URL: https://aur.archlinux.org/nvidia-full-beta-all.git (read-only)
Keywords: lib32-opencl-driver lib32-vulkan-driver libglvnd nvidia-settings opencl-driver vulkan-driver
Submitter: Det
Maintainer: dbermond
Last Packager: dbermond
Votes: 32
Popularity: 0.004245
First Submitted: 2013-06-27 12:48
Last Updated: 2019-11-10 11:56

AnAkkk commented on 2013-11-03 00:55

It won't break your package as with the new official patch it should work with any kernel.

Det commented on 2013-11-02 19:33

@Commander, 1) it was the previous patch he was referring to, and 2) obviously?

Commander commented on 2013-11-02 19:19

@AnAkkk
where does it use the totalram_pages, looked at the 325-331.patch but i'm probably blind this time of day.

Also reading the last post in the gentoo forum post
"2nd, num_physpages was renamed to totalram_pages, use this one instead."

@Det
The if will only work for 3.11 kernels that's why he told you to remove it since he uses 3.12 kernel.

Looking at it this patch is needed for 3.11 and above so maybe apply the if statement like
if [[ ${_kernver} >= 3.11* ]]; then

Simple fix and should work no?

Det commented on 2013-11-02 15:29

Why would you?

I don't want to break my package.

AnAkkk commented on 2013-11-02 11:23

Thanks. There's still a problem, it won't compile with linux-mainline (3.12) because you only apply the patch for linux 3.11. You can now apply the patch on any version though, as it detects if get_num_phypages() is available. I would suggest removing the following condition:
if [[ ${_kernver} = 3.11* ]]; then

Det commented on 2013-11-02 08:36

331.17-2

* Use a better patch: http://forums.gentoo.org/viewtopic-t-973960.html

AnAkkk commented on 2013-11-01 13:22

The patch you use seem to be wrong anyway, it uses totalram_pages instead of get_num_physpages().

AnAkkk commented on 2013-10-31 21:04

It might be a good idea to replace the patch with the official one:
https://devtalk.nvidia.com/default/topic/628864/unix-graphics-announcements-and-news/num_physpages-and-support-for-3-11-and-later-kernels/

Commander commented on 2013-10-23 23:12

new nVidia 313.17 released
https://devtalk.nvidia.com/default/topic/625178

Det commented on 2013-08-09 17:33

Mm, doesn't matter if you do because it's a make dependency for nvidia-full-beta-all.