Package Base Details: nvidia-340xx

Git Clone URL: https://aur.archlinux.org/nvidia-340xx.git (read-only, click to copy)
Submitter: simonsmh
Maintainer: JerryXiao (graysky)
Last Packager: JerryXiao
Votes: 50
Popularity: 1.46
First Submitted: 2019-06-07 10:29
Last Updated: 2021-06-06 02:31

Pinned Comments

graysky commented on 2021-05-10 15:03

OK, I honestly forgot that I included an example config file. Since I don't have the hardware for testing, and since I still don't have a sense from users that it is a requirement, I will leave it in the post_install and depend on the user's ability to read pacman's output and manually copy the example over.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

leopseft commented on 2021-03-27 20:06

@tioguda you gave me such a great idea man!!

I completely disabled the DM, I changed the default target to multiuser.target (instead of graphical target) then configured a minimal .xinitrc to start properly the KDE and in the end I automatized startx to autostart after login and finally automatized login user with systemd.service!! Got rid off DMS for good!!

You Rule man! Keep it simple brothers!!

ansgoati commented on 2021-03-27 19:59

@leopseft @auriculaire I just trying to get the nvidia package work, on kernel 5.11.8 i was able to switch to nouveau maintaining the nvidia but after the upgrade and installing the lts kernel xinit can't start, i have sddm.

auriculaire commented on 2021-03-27 16:13

@ansgoati Personally, I didn't try to reinstall "nouveau" because my graphics card (GeForce 9400/integrated/SSE2) is too old, and I know that my pc (mac) often crashed when I first installed archlinux with "nouveau" by default. However, @leopseft gives you a good direction that you can refine by searching the internet. Sorry about that.

leopseft commented on 2021-03-27 04:45

@ansgoati If you want to use nouveau I assume you have already deleted any nvidia.conf in xorg.d, right?

Just tried with the sddm update and the 5.11.10 kernel and still nothing.

Should we report a bug in upstream? Or it will be ignored because it is Nvidia related??!!

tioguda commented on 2021-03-27 01:56

I have been using it without problems since the 5.11.2 kernel, but it is in Manjaro Gnome, another user reported that Manjaro Xfce is starting well too.

I also had to make the change mentioned in my other comment here.

In KDE I can start with startx from tty2.

Greetings.

ansgoati commented on 2021-03-27 01:39

@auriculaire i've installed the lts kernel, recompile the nvidia package and now i can't even use nouveau. What could happen ? What i need to put on Xorg ?? Thanks

auriculaire commented on 2021-03-25 16:25

@leopseft : Yes of course. In fact, with lightdm, only xfce can connect but crashes. Maybe because of the background... But the problem is not due to the kernel nor to the cross-desktop but to the package: nvidia-340xx-dkms 340.108-18 on kernel 5.11....Good day.

leopseft commented on 2021-03-25 14:48

@auriculaire did you add a greeter for Lightdm as well?

auriculaire commented on 2021-03-25 14:43

Lightdm works...(kernel 5.11...) yes, but then no connection is made for desktops like XFCE, Gnome, Cinnamon, KDE plasma ... (same with gdm or sddm)...... But fortunately on Linux-lts (kernel 5.10....) : everything works. Thanks.

thelinuxfan commented on 2021-03-24 05:16

@mischa : I switched to lightdm and it worked!

There's definitely some bug somewhere with SDDM or maybe some configuration changes that are needed and are missing.