Package Base Details: nvidia-340xx

Git Clone URL: https://aur.archlinux.org/nvidia-340xx.git (read-only, click to copy)
Submitter: simonsmh
Maintainer: JerryXiao (graysky)
Last Packager: graysky
Votes: 34
Popularity: 2.80
First Submitted: 2019-06-07 10:29
Last Updated: 2020-04-07 13:20

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

osvcos commented on 2020-02-04 16:10

Hi, this fixes the build: https://pastebin.com/s6y0qNCL

johnhamelink commented on 2020-02-04 10:42

While trying to upgrade this package after upgrading to 5.5.1-arch-1, the build fails as follows: https://gist.github.com/johnhamelink/127d54f07eb70247ad5ac40e89c67d2f

I have also been receiving a conflicted dependencies error between nvidia-340xx-utils and nvidia-340xx-dkms (yay wants to upgrade them both at once). I removed nvidia-340xx-utils to try and unstick this, resulting in my current problem.

I was able to get a working machine again by:

  • Disabling the nvidia modules from initcpio.conf
  • Downgrading the linux and linux-headers packages to 5.4.15-arch1-1:
sudo pacman -U /var/cache/pacman/pkg/linux-headers-5.4.15.arch1-1-x86_64.pkg.tar.zst
sudo pacman -U /var/cache/pacman/pkg/linux-5.4.15.arch1-1-x86_64.pkg.tar.zst
  • Adding linux and linux-headers to /etc/pacman.conf’s ignored packages list
  • Upgrade all dependencies
  • Reboot
  • Re-enabling the nvidia modules in initcpio.conf
  • Re-installing nvidia-340xx-dkms and nvidia-340xx-utils
  • Reboot

I hope this is useful/helpful!

graysky commented on 2020-02-03 21:44

It is ... my mirror was out-of-sync. Need to identify a patch for 5.5.x ... Osvaldo is working on one but if you know of one out there from another distro please share it.

wurbelgrumpff commented on 2020-02-03 21:30

Thanks for the answer, but as far as I never use any [testing] I'm sure that 5.5.x is in [core] now.

graysky commented on 2020-02-03 21:04

When 5.5.x goes into [core] as there is no [testing] for the AUR... also, someone will need to point me to a patch for 5.5.x if I cannot find one myself.

wurbelgrumpff commented on 2020-02-03 20:42

Hi, I've updated to arch Linux 5.5.1, but my graphical Interface will not start yet. Is there any chance to get a 5.5.-patch soon? Thanks a lot in advance!

taz-007 commented on 2020-01-28 19:06

fwiw, it doesn't build anymore with the 5.5.arch1 kernel. (I haven't had time to try to fix it).

willianholtz commented on 2020-01-19 00:12

Sorry for the ignorance, but even with the update my 9300M card, it does not accept the drive, it goes out as soon as I enter the system. Is there anything to do?

pissbrain commented on 2020-01-17 13:58

@Zappo-II the linux package is on version 5.4.12, try updating that first.

Zappo-II commented on 2020-01-17 12:27

For me latest linux-5.4.3 breaks with 340.108-3 (won't switch to gfx in boot anymore, even after rebuilding and stuff), had to revert to linux-5.4.2... Stupid me or anybody else...???