Package Base Details: nvidia-340xx

Git Clone URL: https://aur.archlinux.org/nvidia-340xx.git (read-only, click to copy)
Submitter: simonsmh
Maintainer: JerryXiao (graysky)
Last Packager: JerryXiao
Votes: 50
Popularity: 1.37
First Submitted: 2019-06-07 10:29
Last Updated: 2021-06-06 02:31

Pinned Comments

graysky commented on 2021-05-10 15:03

OK, I honestly forgot that I included an example config file. Since I don't have the hardware for testing, and since I still don't have a sense from users that it is a requirement, I will leave it in the post_install and depend on the user's ability to read pacman's output and manually copy the example over.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

graysky commented on 2021-05-08 10:56

I'm not sure what I can do with your reply. You're modifying the PKGBUILD I provide to build without dkms on a foreign distro and you're reporting that it works. You're not sharing the code you're using to do this so it's impossible to make a comparison back to help users of Arch build via dkms.

What if you uninstall your non-dkms tweaked package and try building with this unmodified. Does that build? If so do it give a functional module?

tioguda commented on 2021-05-08 10:53

Yes, they abandoned it, but I am using this package as a base to build one for Manjaro.

This driver is starting/working with the Manjaro (Gnome) 5.12 kernel and the Zen kernel (compiled locally).

As I mentioned before, I use this package as a base, since small changes are needed to compile the non-dkms module in Manjaro.

Greetings.

graysky commented on 2021-05-08 10:28

I am unfamiliar with manjaro but I thought they dropped this driver a while ago. Are you using the 5.12 kernel there where you report a functional driver? Is it this package you're using to build the kernel module?

tioguda commented on 2021-05-08 01:17

@graysky could you tell me a test to make sure everything is fine with the 5.12 kernel?

In Manjaro Gnome the system starts and I don't have the problems reported by @jayache80. In Plasma I can only start via startx on tty2, I haven't tested it with Xfce.

Greetings.

graysky commented on 2021-05-07 12:39

OK, if this doesn't give a functional module for the 5.12 series of kernels, we need to either 1) identify someone else's work to fix it (ie a patch from another distro or person), or 2) we need someone with expertise to fix it for us. I am not that someone nor do I have any hardware for testing.

nahno commented on 2021-05-07 03:59

I can confirm 2). Tested yesterday. My machine (xfce4) stills runs on Linux 5.11.7 without any issues though.

graysky commented on 2021-05-06 18:33

So there are two independent issues:

1) The patch shared by @qileilu is for the 460 series of drivers and not applicable to this version. 2) The package is-as does not work under 5.12.

Can someone else confirm point #2 is valid? If so, we will need to identify the reason why and see if a known fix is out there.

m31aur commented on 2021-05-06 16:09

Whilst it builds without errors on 5.12, the system is unusable. At least with xfce4 that I am using. (xfwm fails to start). It works brilliantly on 5.10

lucasrizzini commented on 2021-05-06 12:50

The patch below is for 460 version..

graysky commented on 2021-05-06 11:00

I thought this worked with 5.12 without patches. It certainly builds which is all I can do testing-wise.