Package Base Details: nautilus-typeahead

Git Clone URL: https://aur.archlinux.org/nautilus-typeahead.git (read-only)
Keywords: gnome nautilus typeahead
Submitter: badwolfie
Maintainer: albertvaka
Last Packager: albertvaka
Votes: 31
Popularity: 0.709208
First Submitted: 2015-09-11 00:39
Last Updated: 2019-05-08 11:47

Latest Comments

« First ‹ Previous 1 2 3 4 5

jonarnold commented on 2015-09-27 01:25

Here's a link to the old package which used a patch from Ubuntu: http://pkgbuild.com/git/aur-mirror.git/tree/nautilus-typeahead

smcdougall commented on 2015-09-27 01:14

I'm having this issue too. The patch seems to only effect List View / Tree View in Nautilus, where it used to effect Icon View as well.

When in List View, Typeahead works as expected, but in Icon View typing brings up Recursive Search instead.

The patch file toggles "gtk_tree_view_set_enable_search", but it seems like there should be a similar line for Icon View as well.

badwolfie commented on 2015-09-22 23:33

@jonarnold what do you mean by folder view? Like when on a file selector? Cuz there's a package that does that https://aur.archlinux.org/packages/gtk3-typeahead ;)

jonarnold commented on 2015-09-22 12:57

Also, it would be nice if this would patch the folder view as well. I know the old AUR package did this.

jonarnold commented on 2015-09-22 12:49

That worked. Running makepkg from the package build rather than building from yaourt did the trick. Not sure why...

badwolfie commented on 2015-09-21 20:21

@jonarnold not sure... Could you try to compile it locally and see if the source file it's patched correctly?

The file is "src/nautilus-3.16.2/src/nautilus-list-view.c" and it should have searching enabled like this: "gtk_tree_view_set_enable_search (view->details->tree_view, TRUE);" around line 1926

jonarnold commented on 2015-09-21 20:00

I reinstalled, including the replacement of libnautilus-extension, and it still doesn't work. Should I check some log?

badwolfie commented on 2015-09-21 19:14

@jonarnold could you try again and tell me if you keep getting the same result, please? The typeahead feature is working just fine for me

jonarnold commented on 2015-09-19 03:29

I installed this, and it seems to have no effect. Whenever I type, it still brings up the search box.