Package Base Details: mysql

Git Clone URL: https://aur.archlinux.org/mysql.git (read-only)
Submitter: Barthalion
Maintainer: Muflone
Last Packager: Muflone
Votes: 67
Popularity: 0.97
First Submitted: 2013-04-25 19:13
Last Updated: 2019-08-04 13:39

Latest Comments

« First ‹ Previous ... 9 10 11 12 13 14

Anonymous comment on 2013-07-10 04:21

I cannot build this package
==> Making package: mysql 5.6.12-2 (Wed Jul 10 01:13:20 BRT 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found mysql-5.6.12.tar.gz
-> Found mysql-5.6.12.tar.gz.asc
-> Found mysqld-post.sh
-> Found mysqld-tmpfile.conf
-> Found mysqld.service
==> Validating source files with sha256sums...
mysql-5.6.12.tar.gz ... Passed
mysql-5.6.12.tar.gz.asc ... Skipped
mysqld-post.sh ... Passed
mysqld-tmpfile.conf ... Passed
mysqld.service ... Passed
==> Verifying source file signatures with gpg...
mysql-5.6.12.tar.gz ... FAILED (unknown public key 8C718D3B5072E1F5)
==> WARNING: Warnings have occurred while verifying the signatures.
Please make sure you really trust them.
==> Extracting sources...
-> Extracting mysql-5.6.12.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Starting build()...
mkdir: cannot create directory ‘build’: File exists
==> ERROR: A failure occurred in build().
Aborting...
The build failed.
local database is up to date

How should I proceed?

rustam commented on 2013-06-13 09:07

Ah, I see now. On my systems it just throws a warning but doesn't prevent building, and I can see the same in the Arch wiki http://bit.ly/12oPo0W. Not sure why it's the error in your case. The reason for this verification failure is that Oracle's GPG keys are not added to the keyring. So, successful GPG checking would require you to manually init the keyring and import their key, run:

gpg --list-keys
gpg --recv-keys 8C718D3B5072E1F5

Then try installing aur/mysql again, it should resolve the problem. Probably I will need to drop gpg checking in this AUR package, as it makes no sense for me manually adding the signature, or build another package with their keyring and install it prior to MySQL installation as a dependency.

kralibes commented on 2013-06-13 06:13

With yaourt.

Now I see that it's not a checksum error but an error of failing gpg signature - sorry for this.

(german)
==> Überprüfe Signaturen der Quell-Dateien mit gpg...
mysql-5.6.11.tar.gz ... FEHLGESCHLAGEN
==> FEHLER: Eine oder mehrere PGP-Signaturen konnten nicht überprüft werden.
==> ERROR: Makepkg was unable to build mysql.
==> Restart building mysql ? [y/N]
==> ------------------------------

rustam commented on 2013-06-11 18:38

@kralibes: I see no issues with checksums; double checked it and it's valid and the package builds on my machines. Do you use yaourt or manually downloaded the pkgbuild and building in a directory with makepkg? In the latter case, try removing mysql-5.6.11.tar.gz and re-download it.

kralibes commented on 2013-06-11 18:10

No valid checksum for mysql 5.6.11.

rustam commented on 2013-05-29 10:20

MySQL 5.6.11 is the current stable GA release, so I'm gonna update this package to that version shortly. I've submitted the mysql55 package for those who still need v5.5.

Barthalion commented on 2013-05-16 13:01

If you don't have time to compile new release on your own, I uploaded signed packages here: http://repo.bpiotrowski.pl/tmp/mysql/