Package Base Details: mxnet

Git Clone URL: https://aur.archlinux.org/mxnet.git (read-only, click to copy)
Keywords: deep_learning deep_neural_networks distributed_systems machine_learning
Submitter: Godisemo
Maintainer: petronny
Last Packager: petronny
Votes: 9
Popularity: 0.008185
First Submitted: 2017-02-11 00:12
Last Updated: 2020-01-14 06:05

Packages (3)

Pinned Comments

petronny commented on 2019-06-21 08:00

And about this package, I've splitted it into mxnet{,-cuda,-mkl}. And it will take lots of time and space to compile.

The pre-built binaries of mxnet{,-cuda,-mkl} and their dependencies can be found in arch4edu.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

nextAaron commented on 2018-11-14 01:33

What's cuda_call.patch for?

petronny commented on 2018-11-09 06:33

@vuvko Thanks for pointing it out. Fixed now.

vuvko commented on 2018-06-28 12:08

Why package version is not used when cloning repository? Or is package versioning different from mxnet?

sl1pkn07 commented on 2018-04-28 17:09

about python:

https://github.com/apache/incubator-mxnet/issues/8569

sl1pkn07 commented on 2018-04-22 21:17

https://pastebin.com/pmDm6AXZ

any help?

EDIT (https://github.com/apache/incubator-mxnet/issues/10558) ok, with USE_F16C=0 seems workground the error (or -DCOMPILER_SUPPORT_MF16C=OFF if use cmake)

and test the python part, same fail (coredump) like other users, tested with cmake or make

roachsinai commented on 2018-03-26 21:37

Same issue :-(.

free(): invalid pointer /tmp/yaourt-tmp-roach/aur-mxnet/./PKGBUILD: 行 50: 20759 已放弃 (核心已转储)python setup.py build --with-cython ==> 错误: 在 build() 中发生一个错误。 正在放弃... ==> 错误:Makepkg 无法构建 .

domschl commented on 2018-03-04 09:42

I've had the same issue as @domanov. Build fails during python setup.py build with segmentation fault. Any suggestions what can be done to narrow this down?

petronny commented on 2018-03-04 08:15

Hi, @domanov I can't reproduce your problem. You can install the binary build from https://mirrors.tuna.tsinghua.edu.cn/arch4edu/

domanov commented on 2018-03-02 17:27

Hi, I am not able to compile mxnet, it fails with segmentation error at the end when python setup.py

PKGBUILD: line 39: 17500 Segmentation error (core dump created) python setup.py build

Any hints?

asitdepends commented on 2018-02-11 15:01

It's strange. In my system the build is successful. If I remove cblas or -lcblas flag, I get the same error on 'cblas_ssyrk'. readelf -Ws /usr/lib/libcblas.so | grep cblas_ssyrk confirms that the symbol is there and I believe the linking should be sucessful.