Package Base Details: med

Git Clone URL: https://aur.archlinux.org/med.git (read-only, click to copy)
Submitter: None
Maintainer: Nim65s
Last Packager: Nim65s
Votes: 95
Popularity: 3.35
First Submitted: 2007-09-25 18:28
Last Updated: 2020-04-28 08:16

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

alfredo.ardito commented on 2019-07-23 10:40

Nim65s: yes I did. Everything works fine. thx

greyltc commented on 2019-07-23 08:32

We have med-openmpi for a med package with openmpi. Please fix this to not depend on openmpi.

You can start with changing the hdf5-openmpi dep to be hdf5

Rhinoceros commented on 2019-07-22 22:54

I'm getting a swathe of errors when building, e.g.

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python3.7/py_compile.py", line 154, in compile
    os.makedirs(dirname)
  File "/usr/lib/python3.7/os.py", line 221, in makedirs
    mkdir(name, mode)
PermissionError: [Errno 13] Permission denied: '/usr/lib/python3.7/site-packages/med/__pycache__'

It's unclear if it affects anything though.

Nim65s commented on 2019-07-22 22:15

alfredo.ardito: you can install hdf5-openmpi, can't you ?

alfredo.ardito commented on 2019-07-22 20:45

Hi
:: hdf5-openmpi and hdf5 are in conflict
how do i solve this issue?

Nim65s commented on 2019-07-22 16:55

Thanks. I updated the dependency, and added -DMEDFILE_USE_MPI=ON -DMEDFILE_BUILD_PYTHON=ON.

capitalaslash commented on 2019-07-22 07:13

You need hdf5-openmpi to use MEDFILE_USE_MPI=ON

Nim65s commented on 2019-07-20 06:28

Does it build with this flag for you ? On my system:

…/med/src/med-4.0.0/include/medfile.h:51:15: error: unknown type name 'MPI_Comm'

and more.

And if I add a #include <mpi.h>, I run into more errors: /usr/include/openmpi/ompi/mpi/cxx/functions.h:71:1: error: conflicting declaration of C function 'void MPI::Init()'

jedbrown commented on 2019-07-19 19:10

Since this package already depends on openmpi, could you add -DMEDFILE_USE_MPI=ON so that MEDparFileOpen() will become available?

greyltc commented on 2019-05-21 16:24

Can you make this conflict with the med3 package?