Package Base Details: looking-glass

Git Clone URL: https://aur.archlinux.org/looking-glass.git (read-only, click to copy)
Submitter: Omar007
Maintainer: Omar007
Last Packager: Omar007
Votes: 14
Popularity: 0.67
First Submitted: 2017-12-22 16:49
Last Updated: 2020-05-07 19:36

Latest Comments

« First ‹ Previous 1 2

darthvader commented on 2019-06-16 05:37

Installation fails but looking-class command works fine

Install the project...
-- Install configuration: ""
-- Installing: /tmp/looking-glass/pkg/looking-glass-host/usr/bin/looking-glass-host
==> Tidying install...
  -> Removing libtool files...
  -> Purging unwanted files...
  -> Removing static library files...
  -> Stripping unneeded symbols from binaries and libraries...
  -> Compressing man and info pages...
==> Checking for packaging issues...
==> WARNING: Package contains reference to $srcdir
usr/bin/looking-glass-host
==> Creating package "looking-glass-host"...
  -> Generating .PKGINFO file...
  -> Generating .BUILDINFO file...
  -> Generating .MTREE file...
  -> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: looking-glass 1:B1_rc5-2 (Sun 16 Jun 2019 02:08:36 PM)
==> Installing looking-glass package group with pacman -U...
loading packages...
resolving dependencies...
looking for conflicting packages...

Packages (4) dkms-2.7.1-1  looking-glass-1:B1_rc5-2  looking-glass-host-1:B1_rc5-2  looking-glass-module-dkms-1:B1_rc5-2

Total Installed Size:  2.87 MiB

:: Proceed with installation? [Y/n] 
(4/4) checking keys in keyring                                                                                                 [############################################################################] 100%
(2/4) checking package integrity                                                                                               [############################################################################] 100%
(2/4) loading package files                                                                                                    [############################################################################] 100%
(4/4) checking for file conflicts                                                                                              [############################################################################] 100%
(4/4) checking available disk space                                                                                            [############################################################################] 100%
:: Processing package changes...
(1/4) installing looking-glass                                                                                                 [############################################################################] 100%
(2/4) installing dkms                                                                                                          [############################################################################] 100%
Optional dependencies for dkms
    linux-headers: build modules against the Arch kernel [installed]
    linux-lts-headers: build modules against the LTS kernel
    linux-zen-headers: build modules against the ZEN kernel
    linux-hardened-headers: build modules against the HARDENED kernel
(3/4) installing looking-glass-module-dkms                                                                                     [############################################################################] 100%
(4/4) installing looking-glass-host                                                                                            [############################################################################] 100%
:: Running post-transaction hooks...
(1/2) Install DKMS modules
==> dkms install looking-glass/B1_rc5 -k 5.1.9-arch1-1-ARCH
Error! Bad return status for module build on kernel: 5.1.9-arch1-1-ARCH (x86_64)
Consult /var/lib/dkms/looking-glass/B1_rc5/build/make.log for more information.
(2/2) Arming ConditionNeedsUpdate...
==> Removing installed dependencies...
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: looking-glass: removing sdl2_ttf breaks dependency 'sdl2_ttf'
==> WARNING: Failed to remove installed dependencies.

==> ERROR: An unknown error has occurred. Exiting...
User defined signal 1
$ cat /var/lib/dkms/looking-glass/B1_rc5/build/make.log
DKMS make.log for looking-glass-B1_rc5 for kernel 5.1.9-arch1-1-ARCH (x86_64)
Sun 16 Jun 2019 02:08:49 PM
make: Entering directory '/usr/lib/modules/5.1.9-arch1-1-ARCH/build'
scripts/Makefile.build:42: /var/lib/dkms/kvmfr/0.1/build/Makefile: No such file or directory
make[1]: *** No rule to make target '/var/lib/dkms/kvmfr/0.1/build/Makefile'.  Stop.
make: *** [Makefile:1571: _module_/var/lib/dkms/kvmfr/0.1/build] Error 2
make: Leaving directory '/usr/lib/modules/5.1.9-arch1-1-ARCH/build'

Omar007 commented on 2019-06-04 21:11

Ah yes I see what's going on. I updated the package to use the upstream dkms.conf instead but didn't realize that the upstream file is expecting a hard-coded path.

This is a bit more annoying as I don't see a way to supply/use the upstream dkms.conf without breaking Arch DKMS conventions...

EDIT: Taking another look at the upstream dkms.conf and it looks like this might be an exact rip from the debian wiki with just the PACKAGE_NAME adapted. It also def. doesn't need to rebuild the initrd or be included in one; as far as I'm aware there is no reason at all for this module to be available before the initrd kernel hand-over. I might just switch back to the previously used dkms.conf

EDIT2: Also found that the Makefile is actually overruling dkms itself so it technically already failed in the past if you had multiple kernels installed, even with the 'working' dkms.conf. Holding off until I can provide a fix to upstream for this.

EDIT3: Submitted a patch for the Makefile upstream. Will continue on this later.

EDIT4: Upstream merged, pulling in that specific patch to this package in a bit.

kantras commented on 2019-06-04 19:44

Theres a problem with the DKMS package - you install it under /usr/src as module looking-glass, with version B1-rc5, however the dkms.conf file makes reference to module name kvmfr, version 0.1, and thus can't find the build files.

Omar007 commented on 2019-06-04 17:16

I'm fairly sure I did..

EDIT: Ah forgot to take it out of the makedepends. I'll fix that in a bit

EDIT2: Pipeline is running, should be pushed here in a bit automatically.

gnif commented on 2019-06-04 16:56

You're correct in that it's still a release candidate and B1 will be the official release.

Please remove the dependency on libconfig, it is no longer required.

Omar007 commented on 2019-06-02 16:07

@WeenieHut: I've unflagged the package as the B1 series is just a set of rc tags atm and not marked as a release yet. Since the repo has been using explicit releases I'm still assuming B1 will become one as well and I will update accordingly when it does.

EDIT: Actually, I hadn't noticed the main website change yet and it shows the RC ones as the main downloads atm. I will update the package.

EDIT2: Updated

qubidt commented on 2019-03-17 19:56

Heads up: this release (a12) of looking-glass won't build against the current version (0.12.15) of spice-protocol because looking-glass was using a deprecated header file that was removed in spice-protocol commit 334cef5. This wasn't fixed until LookingGlass#126 was merged in.

Unfortunately, the current PKGBUILD (version a12-1) will remain broken until a) a new upstream release or b) we backport that fix. Here's a PKGBUILD patch for b)

diff --git a/PKGBUILD b/PKGBUILD
index af6ec39..6e70b88 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,24 @@
 pkgbase=looking-glass
 pkgname=("${pkgbase}" "${pkgbase}-module-dkms")
 pkgver=a12
-pkgrel=1
+pkgrel=2
 pkgdesc="An extremely low latency KVMFR (KVM FrameRelay) implementation for guests with VGA PCI Passthrough"
 url="https://looking-glass.hostfission.com"
 arch=('x86_64')
 license=('GPL2')
 makedepends=('cmake' 'sdl2_ttf' 'glu' 'fontconfig' 'libconfig' 'spice-protocol')
 source=("https://github.com/gnif/LookingGlass/archive/${pkgver}.tar.gz"
+        "https://github.com/gnif/LookingGlass/commit/2567447b24b28458ba0f09c766a643ad8d753255.patch"
         "dkms.conf")
 sha512sums=('72fa8bd1f8ced79bbd81784f9a8502cc39b9eea4d74caf7d27a98da29a2aa58abe71349661800f0b16cecd477ffb6b9a71e35abb68b942f3dad54fe339a70c47'
+            '267729736dcb329ce5e5f6524cb9cce20e8b2222fa92644a56d83a937d73bd6efa0b10ab5cda75d1f51e83a6e9cce81afe0ca734005971c869fe61c107b84771'
             'e1f6cd6aabd336d2af97b44a2746e5a0b41d5d5942993379b1284d1cc8d4981fced0ae44d8105709f2bc45a939dfc7f229018c680b0742c3f0778fe28ba301f8')

+prepare() {
+   cd "${srcdir}/LookingGlass-${pkgver}"
+   patch --verbose --forward -p1 --input="${srcdir}/2567447b24b28458ba0f09c766a643ad8d753255.patch"
+}
+
 build() {
    cd "LookingGlass-${pkgver}/client"
    cmake .

Omar007 commented on 2019-02-11 08:36

It completes install just fine without any headers; it doesn't depend on headers, 'looking-glass-module-dkms' depends on DKMS. In turn, you do need kernel headers for DKMS to do anything but that does not have to be 'linux-headers'. It depends on your system what headers are needed. Maybe you even need several if you run multiple kernels. You can install those at any point in time and DKMS will (re-)build all installed modules at that time, including this one. Also see https://wiki.archlinux.org/index.php/Dynamic_Kernel_Module_Support

ghidra commented on 2019-02-11 05:59

This package also requires "linux-headers". Without, does not complete install.

rio commented on 2018-12-16 16:53

For a12 the build system changed to CMake, so to update the PKGBUILD change the version to a12, update the sha512sums, add cmake to makedepends and replace the build-block by

build() {
    mkdir -p "LookingGlass-${pkgver}/client/bin"
    cd "LookingGlass-${pkgver}/client/bin"
    cmake ../ 
    make
}