Package Base Details: linux-nitrous

Git Clone URL: https://aur.archlinux.org/linux-nitrous.git (read-only, click to copy)
Keywords: clang clearlinux hardened kernel linux optimized wireguard zen
Submitter: superboringdev
Maintainer: superboringdev
Last Packager: superboringdev
Votes: 7
Popularity: 0.22
First Submitted: 2019-11-05 16:41
Last Updated: 2021-04-16 14:28

Pinned Comments

superboringdev commented on 2020-03-23 19:25

The prebuilt kernel is built using Clang/LLVM 11.

The linux-nitrous binary package can be installed by adding following lines to your /etc/pacman/pacman.conf:

[linux-nitrous]
Server = https://github.com/xdevs23/linux-nitrous/releases/latest/download/

Then you can install the package using your AUR helper or pacman (e. g. sudo pacman -Syu linux-nitrous linux-nitrous-headers)

You probably need to add my key before being able to install my packages:

sudo pacman-key --recv-keys E9C2DECAC962CB3AF1376D44148A9E3C9C3E3BF0
sudo pacman-key --lsign-key E9C2DECAC962CB3AF1376D44148A9E3C9C3E3BF0

Latest Comments

« First ‹ Previous 1 2 3 4 5 6

superboringdev commented on 2020-02-01 14:40

!!! Important for nvidia-dkms users !!!

Please wait for the release of an updated nvidia-dkms package (probably the one in testing channel, 440.44-16) otherwise you won't be able to make the nvidia driver work with this (5.5)

Alternatively, as a workaround, edit /etc/pacman.conf, move the testing repository to the very bottom and uncomment it. Then just pacman -Syu testing/nvidia-dkms

toki1990 commented on 2019-11-07 17:54

(1/1) yükleniyor linux-nitrous [-----------------------] 100%

Updating module dependencies. Please wait ... Generating initial ramdisk, using mkinitcpio. Please wait... /usr/bin/mkinitcpio: satır 265: /etc/mkinitcpio.d/linuxlinux-nitrous.preset: Böyle bir dosya ya da dizin yok ==> ERROR: Failed to load preset: `/etc/mkinitcpio.d/linuxlinux-nitrous.preset' hata: komut düzgün çalıştırılamadı linux-nitrous için opsiyonel bağımlılık(lar) linux-nitrous-headers: to build DKMS modules against this kernel :: Bağlantılı işlemler listesi çalışıyor... (1/2) Arming ConditionNeedsUpdate... (2/2) Updating module dependencies...