Package Base Details: linux-lqx

Git Clone URL: https://aur.archlinux.org/linux-lqx.git (read-only, click to copy)
Keywords: bfq muqss zen
Submitter: akurei
Maintainer: sir_lucjan (damentz)
Last Packager: damentz
Votes: 135
Popularity: 1.42
First Submitted: 2011-08-08 16:08
Last Updated: 2021-01-16 16:14

Pinned Comments

damentz commented on 2020-08-31 15:22

Official binaries of linux-lqx, linux-lqx-headers, and linux-lqx-docs are now available: https://wiki.archlinux.org/index.php/Unofficial_user_repositories#liquorix

Signing key import instructions: sudo pacman-key --keyserver hkps.pool.sks-keyservers.net --recv-keys 9AE4078033F8024D && sudo pacman-key --lsign-key 9AE4078033F8024D

Latest Comments

« First ‹ Previous ... 91 92 93 94 95 96 97 98 99 100 101 ... Next › Last »

silvik commented on 2012-01-20 23:04

looks like lqx config does not enable the new broadcom drivers (brcmsmac) as mainline arch does.

if you have a broadcom wifi (like me) you need to edit the PKGBUILD to enable menuconfig (_menu="m"). in the menuconfig disable BCMA support (in Broadcom specific AMBA section) and enable Broadcom IEEE802.11n PCIe SoftMAC WLAN driver (in Network devices / Wireless LAN)

is it possible to make this small change in the lqx package config? thanks.

silvik commented on 2012-01-20 23:03

looks like lqx config does not enable the new broadcom drivers (brcmsmac) as mainline arch does.

if you have a broadcom wifi (like me) you need to edit the PKGBUILD to enable menuconfig (_menu="n"). in the menuconfig disable BCMA support (in Broadcom specific AMBA section) and enable Broadcom IEEE802.11n PCIe SoftMAC WLAN driver (in Network devices / Wireless LAN)

is it possible to make this small change in the lqx package config? thanks.

Wintershade commented on 2012-01-20 18:45

@shivik, it compiles and works well. virtualbox module doesn't work due to different issues on my system - however a package nvidia-all compiles and works like a charm (I'm using it rather than your nvidia-lqx due to a number of other kernels I'm testing whenever I can).
So anyway, absolutely positive feedback from me. Kudos!

shivik commented on 2012-01-19 15:05

@Wintershade, there you go: http://netload.in/dateiodASThlZAo/linux-lqx-3.2.1-2_with_extramodules.tar.gz.htm
Compiled and installed fine on my system. So it works for me.
Give it a shot and let me know if it works for you.

shivik commented on 2012-01-19 11:01

For anyone having issues booting with with nvidia driver use amd_iommu=off or intel_iommu=off(depending on your motherboard chipset).
Chances are high that you'll be able to boot to graphical environment.

@Wintershade - I'll work on that.

Wintershade commented on 2012-01-18 19:59

Could you please add support for external modules (i.e. /lib/modules/extramodules-XY)?
Without those, external modules (such as virtualbox driver) won't work...

shivik commented on 2012-01-18 06:35

That's because the package was out of date(a 3.2.1-2 patch was released).
It's updated now so you shouldn't have problems.

Anonymous comment on 2012-01-17 20:58

I am trying it install the liquorix kernel and I get the following error.
I think it is trying to download 3.2.1-1.patch.gz which doesn't exist.

==> Making package: linux-lqx 3.2.1-1 (Tue Jan 17 14:53:14 CST 2012)
==> Checking runtime dependencies...
warning: config file /etc/pacman.conf, line 33: directive 'ShowSize' in section 'options' not recognized.
==> Checking buildtime dependencies...
==> Retrieving Sources...
-> Downloading linux-3.2.tar.xz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 62.0M 100 62.0M 0 0 305k 0 0:03:28 0:03:28 --:--:-- 300k
-> Downloading 3.2.1-1.patch.gz...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (22) The requested URL returned error: 404
==> ERROR: Failure while downloading 3.2.1-1.patch.gz
Aborting...

shivik commented on 2012-01-17 18:04

No problem.Just exit and the build process will continue normally.
It's back to how it was before(no menuconfig).
This nvidia issue is driving me crazy.
Downgraded to 3.1.8 and the problem is gone.
The moment I switch to 3.2.1 and I get a black screen.

silvik commented on 2012-01-17 16:42

i get the make menuconfig configuration dialog. is this ok?