Package Base Details: linux-amd-staging-drm-next-git

Git Clone URL: https://aur.archlinux.org/linux-amd-staging-drm-next-git.git (read-only)
Keywords: amd amdgpu dal dc radeon vega
Submitter: yurikoles
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 19
Popularity: 0.73
First Submitted: 2017-08-24 18:09
Last Updated: 2019-09-26 23:56

Pinned Comments

yurikoles commented on 2017-09-25 18:29

Pull-requests are welcome: https://github.com/yurikoles/linux-amd-staging-drm-next-git

Please report bugs upstream: https://bugs.freedesktop.org/ or amd-gfx mailing list.

Please make sure that build output is not localized by adding LC_ALL=C in front of command that you use to build a kernel, e.g. LC_ALL=C makepkgs -si

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

yurikoles commented on 2019-01-04 22:12

@mikearch I put 4.21 in pkgver, because this branch contains material that is targeted for 4.21, but Makefile contains 4.20rc3, and this version is used for compatibility with dkms and others.

mikearch commented on 2019-01-04 22:04

It pulls,builds and install 4.20rc3 for me. It says it's pulling and building 4.21, but it says it's preparing 4.20rc3. Installing it and running it with a uname shows me it's running 4.20rc3. Did something change in the script?

Feanor1397 commented on 2018-12-08 19:35

Missing arch/x86/kernel/macros.s when building modules with dkms

Teyro commented on 2018-11-28 15:18

Hi there,

Is there a chance to get the main kernel with patches? 4.20 is to new for some kernel modules....

yurikoles commented on 2018-11-02 08:49

@gort818 fixed

gort818 commented on 2018-11-01 23:39

Failed to validate config.x86_64 ... FAILED

yurikoles commented on 2018-08-21 06:14

Привет, @robus!

Please follow updated instructions in pinned post.

robus commented on 2018-08-19 13:03

Build failed on my system :(

...

LD [M] drivers/scsi/hv_storvsc.o

LD [M] drivers/scsi/sd_mod.o

CC [M] drivers/usb/serial/mxuport.o

LD [M] drivers/scsi/sr_mod.o

CC [M] drivers/usb/serial/navman.o

CC [M] drivers/usb/serial/omninet.o

CC [M] drivers/usb/serial/opticon.o

CC [M] drivers/usb/serial/option.o

CC [M] drivers/usb/serial/oti6858.o

CC [M] drivers/usb/serial/pl2303.o

CC [M] drivers/usb/serial/qcaux.o

CC [M] drivers/usb/serial/qcserial.o

CC [M] drivers/usb/serial/quatech2.o

CC [M] drivers/usb/serial/safe_serial.o

CC [M] drivers/usb/serial/sierra.o

CC [M] drivers/usb/serial/usb-serial-simple.o

CC [M] drivers/usb/serial/spcp8x5.o

CC [M] drivers/usb/serial/ssu100.o

CC [M] drivers/usb/serial/symbolserial.o

CC [M] drivers/usb/serial/usb_wwan.o

CC [M] drivers/usb/serial/ti_usb_3410_5052.o

CC [M] drivers/usb/serial/upd78f0730.o

CC [M] drivers/usb/serial/visor.o

CC [M] drivers/usb/serial/wishbone-serial.o

CC [M] drivers/usb/serial/whiteheat.o

CC [M] drivers/usb/serial/xsens_mt.o

LD [M] drivers/usb/serial/usbserial.o

AR drivers/usb/built-in.a

AR drivers/built-in.a

==> ERROR: A failure occurred in build().

Aborting...

https://dpaste.de/QrOW

yurikoles commented on 2018-08-19 09:58

@LiberteCzech

This prefix is needed to see non-localized output. Please paste non-localized output to some paste site (e.g. https://dpaste.de/) and post a link to it.

LiberteCzech commented on 2018-08-18 20:39

Hi @yurikoles

Sorry, I do not know how. I use yaourt.

I try add:

LC_ALL=C

LC_ALL=cs_CZ.UTF-8

to /etc/locale.conf

And write directly to terminal. But it's not help.