Package Base Details: libssh-gnutls

Git Clone URL: https://aur.archlinux.org/libssh-gnutls.git (read-only)
Submitter: frealgagu
Maintainer: frealgagu
Last Packager: frealgagu
Votes: 9
Popularity: 0.036702
First Submitted: 2018-11-09 17:08
Last Updated: 2019-07-01 17:05

Pinned Comments

frealgagu commented on 2018-11-10 13:38

If you are having problems installing this package due to signature verification, please run the below before running makepkg:

gpg --receive-keys 7EE0FC4DCC014E3D

If makepkg still complains after this:

1) Ensure you're using makepkg, and not some wrapper.

2) Ensure you don't have GNUPGHOME set in /etc/makepkg.conf or ~/.makepkg.conf, or that the value of GNUGPHOME in makepkg.conf matches that which you've run the above gpg command with.

3) Ensure that the tarball you downloaded matches the md5sums in the PKGBUILD.

Latest Comments

« First ‹ Previous 1 2 3

frealgagu commented on 2018-11-10 13:24

@Vrakfall there are actually two sources in the PKGBUILD, the .tar.xz and the .tar.xz.asc which is the signature file for gpg verification.

Then two sha256sums are needed and commonly the .asc are ignored in sum verification using SKIP.

Vrakfall commented on 2018-11-10 11:58

Why is there a "SKIP" after the checksum?

frealgagu commented on 2018-11-09 20:57

libssh-gnutls provides libssh so you are fine replacing the package.

Provides and conflicts clauses fixed for docs package. Everything should be OK now.

maderios commented on 2018-11-09 19:40

Done, thanks. Other problem, conflict with the two created packages: error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: libssh-gnutls and libssh-gnutls-docs are in conflict Other thing: libssh-gnutls and libssh are in conflict => try/test removing libssh but:

dcmtk: removing libssh breaks dependency 'libssh' :: ffmpeg: removing libssh breaks dependency 'libssh' :: wireshark-cli: removing libssh breaks dependency 'libssh'

frealgagu commented on 2018-11-09 18:12

@maderios you need to import the key via

gpg --receive-keys 7EE0FC4DCC014E3D

maderios commented on 2018-11-09 18:11

Problem: makepkg -sicC libssh-0.8.5.tar.xz ... FAILED (unknown public key 7EE0FC4DCC014E3D)