Package Base Details: lib32-ffmpeg

Git Clone URL: https://aur.archlinux.org/lib32-ffmpeg.git (read-only, click to copy)
Submitter: lano1106
Maintainer: oxalin
Last Packager: oxalin
Votes: 31
Popularity: 0.97
First Submitted: 2013-05-18 04:43
Last Updated: 2021-04-02 19:58

Pinned Comments

oxalin commented on 2018-02-25 07:37

About GPG, it is up to you to import the missing public key. If you receive an error about it, this is ffmpeg's project public key. Something like the following should do the trick: gpg --recv-keys B4322F04D67658D8

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

oxalin commented on 2020-06-19 16:07

@programegg : that's annoying. I'll see what is going on with it. Last commit (when accessing its git repository) was June 6th 2020. I was able to retrieve the PKGBUILD if for any reason we need to recreate it.

That being said, this could be because the package is being moved elsewhere (multilib). So I'll wait a bit and come back later.

programegg commented on 2020-06-19 15:49

Impossible to build due to missing required package lib32-x264. AUR page for missing package appears to have been deleted.

oxalin commented on 2020-06-09 15:19

@Samega7Cattac : which version of aom and lib32-aom packages is installed?

Samega7Cattac commented on 2020-06-08 14:36

/usr/bin/ld: libavcodec/libavcodec.so: undefined reference to `aom_codec_control'
collect2: error: ld returned 1 exit status
make: *** [Makefile:111: ffmpeg_g] Error 1
make: *** Waiting for unfinished jobs....
/usr/bin/ld: libavcodec/libavcodec.so: undefined reference to `aom_codec_control'
/usr/bin/ld: libavcodec/libavcodec.so: undefined reference to `aom_codec_control'
collect2: error: ld returned 1 exit status
make: *** [Makefile:111: ffplay_g] Error 1
collect2: error: ld returned 1 exit status
make: *** [Makefile:111: ffprobe_g] Error 1
==> ERROR: A failure occurred in build().

Iglu47 commented on 2020-04-07 07:26

check that lib32-x265 has the same version as x265, else else it will give the error that ~pkg-conf not found x265

oxalin commented on 2019-08-30 19:00

@sl1pkn07 please, how did you come to that conclusion? I asked the same question in another package. Many lib32 packages, even officials, use the provide option without any problem with their native x64 counterparts. On my side, I don't have any drawback causes by the provides option.

sl1pkn07 commented on 2019-08-30 14:47

please remove libavcodec.so, libavdevice.so, libavfilter.so, libavformat.so, libavutil.so, libpostproc.so, libswresample.so, libswscale.so in provides. break ffmpeg package

Strunkenbold commented on 2019-07-20 08:16

@QuartzDragon

Thx for finding the issue. Unfortunately lib32-x265 is still at 3.0...

QuartzDragon commented on 2019-07-17 07:11

Turns out to have been caused by a version mismatch between the 64-bit and 32-bit x265 libraries. I use the testing repos, which supplies x265 3.1. lib32-x265 is 3.0. Upgrading lib32-x265 to 3.1 allowed lib32-ffmpeg to find the library.

lib32-ffmpeg is then seemingly using pkg-config to find the 64-bit x265 version, and derive the 32-bit version from that, so it's no wonder that lib32-ffmpeg couldn't find it...

oxalin commented on 2019-07-16 15:39

Well, everything seems fine. On my side, I removed lib32-x265 and lib32-ffmpeg before reinstalling them and everything went just fine. Could you delete your lib32-ffmpeg build folder in case it is keeping something wrong from a previous installation? It could be under ~/.cache/<yourselectedAURtool>/