Package Base Details: kodi-standalone-service

Git Clone URL: https://aur.archlinux.org/kodi-standalone-service.git (read-only, click to copy)
Submitter: graysky
Maintainer: graysky
Last Packager: graysky
Votes: 61
Popularity: 0.001945
First Submitted: 2014-11-05 20:25
Last Updated: 2020-02-02 19:47

Latest Comments

1 2 3 4 5 6 ... Next › Last »

graysky commented on 2020-02-02 19:54

@ghen - Good idea, https://github.com/graysky2/kodi-standalone-service/commit/74abcce02a98f51a56fa4ab52d56432007c60575

ghen commented on 2020-02-02 18:39

Hi, could you add StandardOutput=journal to the unit file, to avoid it to inherit from StandardInput=tty and print xinit output on the screen? (which no other unit does) This allows to get a https://wiki.archlinux.org/index.php/Silent_boot :)

graysky commented on 2020-01-12 11:47

@asm0dey - If you want to override the package provided files, place your own in /etc/sysusers.d/ ... see man sysusers.d

asm0dey commented on 2020-01-11 22:07

@graysky I mean mark .conf and .service files as backup, please

graysky commented on 2020-01-08 23:53

Arch ARM is not Arch. They are not the same platform and within Arch ARM there are different platforms. Arch ARM kodi packages ship with their own kodi.service that works on it.

stuartiannaylor commented on 2020-01-08 21:17

Thats a shame then as need a common install across platforms. I will go back to creating my own service prob then, just noticed you in the Arch Linux Arm forum in the kodi section so was wondering if that was your intent.

The update works fine though but for some strange reason fails on first reboot then works :)

graysky commented on 2020-01-08 19:28

This package is NOT for any Arch ARM kodi. x86_64 only!

stuartiannaylor commented on 2020-01-08 19:02

I will give it a go the install is trashed at the moment with windows as it turned out to be lack of signal on a dvb.

I did do a fresh install of just xorg normal kodi and the startx worked for me but will try yours again. Prob be a couple of days as playing with the Pi4. Are you trying the same with Pi4? as interested?

graysky commented on 2020-01-08 13:27

@stuart - I updated to 1.98-1 a few min ago. Try this:

# systemctl stop kodi (or kodi-gbm)
# userdel kodi
# groupdel kodi
# rm /etc/X11/Xwrapper.config
# pacman -Rs kodi-standalone-service (or gbm if you use that)

Reboot, then build/install 1.98. Does it work as intended?

stuartiannaylor commented on 2020-01-08 12:24

Nope Graysky apols as haven't played with Arch for over a year and its like starting anew so just getting up to speed. I am not sure what it is maybe its my EFI arch install but even with a pacman -U it just hands at reached graphical target. 2 days ago it just installed no problem think that was without a EFI boot part but only difference.

Anyone done a fresh install in the last day or so?

Also did the /etc/X11/Xwrapper.config which should contain the following:

needs_root_rights = yes