Package Base Details: kodi-git

Git Clone URL: https://aur.archlinux.org/kodi-git.git (read-only)
Submitter: BlackIkeEagle
Maintainer: graysky
Last Packager: graysky
Votes: 83
Popularity: 0.623496
First Submitted: 2014-10-23 06:38
Last Updated: 2019-06-27 22:51

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

cspack77 commented on 2018-06-03 23:45

lirc is now a make dependency. https://github.com/xbmc/xbmc/commit/6e156bea5bf3a7fb8967e888238b6a07b967a90b

fleixi commented on 2018-05-12 16:48

Since the last ffmpeg update to Version 1:3.4.2-2 kodi is compile without error but start with this error:

ffmpeg[7FFAACA5C900]: Invalid return value 0 for stream protocol 12:11:39.467 T:140714615097600 DEBUG: Previous line repeats 5 times. 12:11:39.467 T:140714615097600 ERROR: Could not find suitable input format: image/png

and segfault.

If i enable the buildin ffmpeg from kodi in the package.conf kodi is working again but is logical bigger and i like to get rid of double packages.

Im the onlyone with this problem?

Niklas commented on 2018-03-24 22:31

@sarvex: This is not possible because the dynamic version number is calculated from the amount of commits on Git since the last major release.

sarvex commented on 2018-03-24 14:58

It would be really save some bandwidth if the archive tarball is used for sources

source=("https://github.com/xbmc/xbmc/archive/master.tar.gz")

Lenovsky commented on 2018-03-22 16:52

Sure, till the end of the week should be done ;)

Niklas commented on 2018-03-20 20:08

Could you modify the PKGBUILD so the resulting packages provide the specific version of Kodi (e.g. provides=("kodi=${pkgver}") )? Also, kodi-dev needs provides=("kodi-dev") please.

Lenovsky commented on 2018-01-15 23:13

@beojan, sorry I'm late. I can't confirm either, it builds without any problems here. Have you tried to build with the manual approach?

Niklas commented on 2018-01-15 20:37

This is how my PKGBUILD looks like, haven't seen any important which could change the build's outcome. https://github.com/flak3/reposource/blob/master/unstable/kodi-git/PKGBUILD

I always build my packages in a clean chroot though. I have a working copy in my repo if you need it.

beojan commented on 2018-01-15 10:13

Niklas: Have you edited the PKGBUILD in any way?

Niklas commented on 2018-01-14 20:55

Cannot confirm, builds without issues.