Package Base Details: julia-git

Git Clone URL: https://aur.archlinux.org/julia-git.git (read-only, click to copy)
Submitter: mihi
Maintainer: TrialnError
Last Packager: TrialnError
Votes: 52
Popularity: 0.087475
First Submitted: 2012-02-22 08:57
Last Updated: 2019-05-22 21:58

Packages (2)

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 13 14 15 ... Next › Last »

videan42 commented on 2013-12-21 18:29

I made an updated patch for the Makefile here.
https://gist.github.com/videan42/8072963

Just replace the current patch with this one and update the MD5 in the PKGBUILD.
MD5: d0e9320a8abd7383cdd0f89cec22e789

epitron commented on 2013-12-19 10:31

The Makefile patch is still failing:

==> Starting prepare()...
patching file Makefile
Hunk #1 FAILED at 160.
1 out of 1 hunk FAILED -- saving rejects to file Makefile.rej
==> ERROR: A failure occurred in prepare(). Aborting...

TrialnError commented on 2013-12-06 01:06

Thanks for the note and I will upload the new version soon

TrialnError commented on 2013-12-06 01:05

Thanks for the note and will upload the new version soon

k8n commented on 2013-12-01 00:02

The Makefile patch fails to apply on recent julia repo checkout.

TrialnError commented on 2013-11-27 18:58

And on another note. Don't flag this package because of upstream releases. Yes, they released 0.2, but this is the git PKGBUILD. As long as it builds, everything is ok. Else I need to submit a new pkgbuild after every comment ;)

Will test again with 0.2 if it's possible to build. Previously this wasn't supported and didn't work

TrialnError commented on 2013-11-27 18:47

@mokasin: The r package is suffice, as it includes those libs. I added librmath, because I don't need the complete r stuff
Just change librmath to r

TrialnError commented on 2013-11-27 18:44

@mokasin: The r package is suffice, as it includes those libs. I added librmath, because I don't need the complete r stuff

mokasin commented on 2013-11-25 21:26

Is there any reason why librmath is exclusivly needed? Or would the r package also suffice? Because librmath conflicts with r.

TrialnError commented on 2013-10-31 01:20

I introduced a patch file with this update. It was in my opinion necessary. Although the SYSCONFDIR var was added I needed to write in package() SYSCONFDIR=$pkgdir/etc which resulted into following warning "WARNING: Package contains reference to $pkgdir" in the final package.
So I decided to introduce DESTDIR so I could split it. And it looks more sane now.
And static libs are added back to the package

In the previous update I removed some of the makedeps as they're part of base and base-devel.