Package Base Details: handbrake-nvenc

Git Clone URL: https://aur.archlinux.org/handbrake-nvenc.git (read-only, click to copy)
Keywords: handbrake nvenc transcode
Submitter: Abzie
Maintainer: Abzie
Last Packager: Abzie
Votes: 1
Popularity: 0.064211
First Submitted: 2019-01-27 18:42
Last Updated: 2020-07-21 23:31

Latest Comments

1 2 3 Next › Last »

rado84 commented on 2021-02-07 14:43

Can anyone test this version to confirm that putting the computer to sleep is actually working? I have the community version but there the sleeping function doesn't work, so I'm looking for alternatives, preferably ones that support nvenc. You can test it by setting 1 or 2 files in queue for conversion, open queue window and choose "put computer to sleep" when done. On the handbrake forum they suggested that I download a deb package but I don't wanna resort to that just yet.

ezacaria commented on 2021-01-04 16:14

First off, happy new year! And sorry about the delayed reply. I sent the patch to disable the dav1d by email.

By the way, if you find that the workaround is useful, there is no need to credit me. Thanks for maintaining this package.

Abzie commented on 2020-12-29 12:16

ezacaria, can you send over the patch via email so I can review.

There is an issue on handbrake with the same dav1d not found using pkg-config problem on Debian unstable so I can include your patch with credit in the PKGBUILD, if verified.

Thanks, Abzie

ezacaria commented on 2020-12-28 18:25

Glad that you managed to build with the dav1d.

The only way I fixed the PKGBUILD so far was disabling dav1d support (I personally have not missed it yet). Maybe I should have been more explicit in my previous post.

One way around is to take out "--enable-libdav1d" and "--enable-decoder=libdav1d" from ${startdir}/src/HandBrake-1.3.3/contrib/ffmpeg/module.defs

I made a small patch for this purpose (easy to include in PKGBUILD) and was able to build it.

As for the other problem, it seems that the current kernel "5.9.14-arch1-1" and nvidia 455.45.01-7 took the initialisation issues away.

sbussetti commented on 2020-12-27 20:46

I was able to do a build from source, and it seems like the Handbrake build itself is bungled. In order to make it work I had to build dav1d into the HandBrake's build/contrib dir where it was expecting it to be.

Not sure how that translates to this PKGBUILD

sbussetti commented on 2020-12-27 19:44

alternatively if I try to run makepkg directly on your PKGBUILD (instead of via aura), I get further, but then fail on:

set -e; /usr/bin/mkdir -p ./contrib/ffmpeg/ffmpeg-4.2.3/; cd ./contrib/ffmpeg/ffmpeg-4.2.3/; CC=/usr/bin/gcc CFLAGS="-I/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build/contrib/include -std=gnu99 -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -mfpmath=sse -msse2" CXX=/usr/bin/g++ CXXFLAGS="-I/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build/contrib/include -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -mfpmath=sse -msse2" CPPFLAGS="-I/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build/contrib/include " LDFLAGS="-L/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build/contrib/lib -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now" PKG_CONFIG_PATH="/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build/contrib/lib/pkgconfig" PATH="/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build/contrib/bin:/home/sol/bin:/home/sol/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/home/sol/.gem/ruby/2.2.0/bin:/usr/lib/jvm/default/bin:/home/sol/.gem/ruby/2.2.0/bin" ./configure --prefix=/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build/contrib/ --disable-shared --enable-static --enable-gpl --disable-doc --disable-programs --disable-avdevice --disable-muxers --disable-network --disable-hwaccels --disable-vdpau --disable-encoders --enable-libmp3lame --enable-encoder=aac --enable-encoder=ac3 --enable-encoder=eac3 --enable-encoder=flac --enable-encoder=mpeg2video --enable-encoder=mpeg4 --enable-encoder=libmp3lame --enable-libopus --enable-encoder=libopus --enable-libspeex --disable-encoder=libspeex --enable-decoder=libspeex --enable-libvpx --disable-decoder=libvpx_* --enable-encoder=libvpx_vp8 --enable-encoder=libvpx_vp9 --disable-decoder=*_crystalhd --enable-libdav1d --enable-decoder=libdav1d --cc="/usr/bin/gcc" --extra-ldflags="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -mfpmath=sse -msse2 -L/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build/contrib/lib" --disable-vaapi --enable-muxer=matroska --enable-muxer=webm --enable-muxer=mov --enable-muxer=mp4 --enable-muxer=psp --enable-muxer=ipod --disable-debug --extra-cflags="-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -D_FORTIFY_SOURCE=2 -mfpmath=sse -msse2 -I/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build/contrib/include -DNDEBUG" --enable-nvenc --enable-encoder=h264_nvenc --enable-encoder=hevc_nvenc
ERROR: dav1d >= 0.2.1 not found using pkg-config

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "ffbuild/config.log" produced by configure as this will help
solve the problem.
make: *** [../contrib/ffmpeg/module.rules:2: contrib/ffmpeg/.stamp.ffmpeg.configure] Error 1
make: Leaving directory '/home/sol/src/handbrake-nvenc/src/HandBrake-1.3.3/build'
==> ERROR: A failure occurred in build().
    Aborting...

sbussetti commented on 2020-12-27 19:20

I'm okay on the pgp sig, but I am hitting:

'm okay on the PGP issue, but currently seeing this:
aura >>= Determining dependencies...
aura >>= AUR Packages:
handbrake-nvenc-cli
aura >>= Continue? [Y/n]
aura >>= Building handbrake-nvenc-cli...
aura >>= Building failed. Would you like to see the error? [Y/n]
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   654  100   654    0     0   3758      0 --:--:-- --:--:-- --:--:--  3758
100 16.0M  100 16.0M    0     0  17.4M      0 --:--:-- --:--:-- --:--:-- 31.2M
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   658  100   658    0     0   4666      0 --:--:-- --:--:-- --:--:--  4666
100   566  100   566    0     0   2471      0 --:--:-- --:--:-- --:--:--  2471
    HandBrake-1.3.3-source.tar.bz2 ... Passed
    HandBrake-1.3.3-source.tar.bz2.sig ... Skipped
    HandBrake-1.3.3-source.tar.bz2 ... Passed
ERROR: download failure; HTTP Error 404: Not Found; continuing.
make[1]: *** No rule to make target 'clean'.  Stop.
make: [../contrib/nvenc/module.rules:2: contrib/nvenc/.stamp.nvenc.build] Error 2 (ignored)
make: *** [../contrib/ffmpeg/module.rules:2: contrib/ffmpeg/.stamp.ffmpeg.configure] Error 1
==> ERROR: A failure occurred in build().
    Aborting...

aura >>= There was a makepkg failure.
aura >>= Would you like to continue anyway? [Y/n]
aura >>= Every package failed to build.

pulsar-nerd commented on 2020-12-03 17:00

People who are having pgp key error. It's a arch pgp issue. Add Ubuntu key server like this.

$ vim ~/.gnupg/gpg.conf

no-greeting  
no-permission-warning  
lock-never  

keyserver hkps://keyserver.ubuntu.com  
#keyserver pool.sks-keyservers.net  
keyserver-options timeout=10  
keyserver-options import-clean  
keyserver-options no-self-sigs-only

ezacaria commented on 2020-11-07 17:05

I disabled the dav1d by patching contrib/ffmpeg/module.defs and managed to build the package. Unfortunately, the nvenc fails to initialize:

[h264_nvenc @ 0x7fc9f05f6980] dl_fn->cuda_dl->cuInit(0) failed -> CUDA_ERROR_UNKNOWN: unknown error

This seems to a situation with the current kernel/driver pair :/ "As mentioned in the news, anything other than pure graphics is currently broken in a nvidia/linux5.9 setup." https://bbs.archlinux.org/viewtopic.php?id=259978

ezacaria commented on 2020-11-06 17:47

There's an error when building: ERROR: dav1d >= 0.2.1 not found using pkg-config

This seems to be a known issue: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=244432

Other variants of handbrake in AUR also seem to be affected.