Package Base Details: handbrake-git

Git Clone URL: https://aur.archlinux.org/handbrake-git.git (read-only, click to copy)
Submitter: haawda
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 105
Popularity: 0.085955
First Submitted: 2015-08-30 09:06
Last Updated: 2021-01-24 19:24

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

haawda commented on 2015-09-28 18:41

prelink and yasm were in the makedepends, but obviously in the wron place, fixed.

piojo commented on 2015-09-27 12:51

Also, I had to install prelink to get the execstack command in PKGBUILD.

piojo commented on 2015-09-27 12:26

It seems yasm is a build dependency. I see it's fetched during the build, but that doesn't seem to help. It only worked after I installed yasm explicitly. (Even fiddling with the path to include the downloaded directory didn't help.) This was the error:

Neither yasm nor nasm have been found

Configuration failed. This could reflect a misconfiguration of your
toolchains, improper options selected, or another problem. If you
don't see any useful error messages above, the next step is to look
at the configure error log file (config.log) to determine what
configure was trying to do when it died.
../contrib/libvpx/module.rules:2: recipe for target 'contrib/libvpx/.stamp.configure' failed

haawda commented on 2015-08-30 09:01

Thanks, did not know that. I am preparing a git-PKGBUILD.

ponsfoot commented on 2015-08-30 07:17

Upstream's source repo has been moved to github.
svn interface seems to be still provided by git-svn but its update is delayed (for about 5 days now, or stopped?).
https://trac.handbrake.fr/wiki/Development

hopimet commented on 2015-08-28 05:35

There is an error in the PKGBUIKD. The "depends" line is splitted (lines 18, 19) as follows:

depends=('dbus-glib' 'desktop-file-utils' 'gst-plugins-base-libs' '
gtk3' 'jansson' 'lame' 'libass' 'libx264' 'libnotify' 'libsamplerate' 'libtheora')

It should be:
depends=('dbus-glib' 'desktop-file-utils' 'gst-plugins-base-libs' 'gtk3' 'jansson' 'lame' 'libass' 'libx264' 'libnotify' 'libsamplerate' 'libtheora')

hopimet commented on 2015-08-28 05:34

There is an error in the PKGBUIKD. The "depends" line is splitted (lines 18, 19) as follows:

depends=('dbus-glib' 'desktop-file-utils' 'gst-plugins-base-libs' '
gtk3' 'jansson' 'lame' 'libass' 'libx264' 'libnotify' 'libsamplerate' 'libtheora')

It should be:
depends=('dbus-glib' 'desktop-file-utils' 'gst-plugins-base-libs' 'gtk3' 'jansson' 'lame' 'libass' 'libx264' 'libnotify' 'libsamplerate' 'libtheora')

haawda commented on 2015-04-04 21:18

pkgver=r7051

adjusted the python script-invokations in the prepare scriptlet.

azleifel commented on 2015-03-14 13:06

pkgver=6985svn

* Just a little PKGBUILD tidying

6985svn is capable of encoding without segfaulting.

azleifel commented on 2015-03-08 11:04

pkgver=6978svn

* Added jansson as a dependency

@haawda: I didn't need to make any additional changes to get 6978svn to build successfully but did find that 6978svn segfaults when starting an encode. I don't know why yet but, for reference, the last good version I've built locally is 6902svn.