Package Base Details: handbrake-git

Git Clone URL: https://aur.archlinux.org/handbrake-git.git (read-only)
Submitter: haawda
Maintainer: FabioLolix
Last Packager: haawda
Votes: 102
Popularity: 0.000224
First Submitted: 2015-08-30 09:06
Last Updated: 2019-05-04 16:05

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

pgug commented on 2016-05-10 07:22

I can't compile the latest version (pkgver=r7200)
It gives the following compile errors
https://gist.github.com/pgug/6e45e98f266c9e849ac068c7d8bbc2a7
If any more informations is needed let me know.

haawda commented on 2016-04-11 02:03

added jansson and libnotify as builddep.

ilikenwf commented on 2016-04-10 21:51

Looks like the current version needs jansson as a build dep.

haawda commented on 2016-04-10 09:36

strange, libnotify already _is_ a dependency.

jamincollins commented on 2016-04-07 17:24

build requirements appear to be incomplete:

checking dynamic linker characteristics... (cached) GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for pkg-config... /bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GStreamer1... no
checking for GHB_GTK_3_14... yes
checking for GHB_GTK_3_12... yes
checking for GHB... no
configure: error: Package requirements (gtk+-3.0 gthread-2.0 gio-2.0 libnotify dbus-glib-1 gmodule-2.0 gudev-1.0) were not met:

No package 'libnotify' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GHB_CFLAGS
and GHB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
../gtk/module.rules:15: recipe for target 'gtk/.stamp.configure' failed
make: *** [gtk/.stamp.configure] Error 1
make: Leaving directory '/tmp/yaourt-tmp-jamin/aur-handbrake-cli-git/src/HandBrake/build'
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build handbrake-git.

ponsfoot commented on 2016-03-09 07:31

Due to the license issue, FDK-AAC is now no longer included by default.
It can be enabled with --enable-fdk option.

https://forum.handbrake.fr/viewtopic.php?f=33&t=34143

haawda commented on 2016-02-06 16:54

I can reproduce now and opened an issue upstream: https://github.com/HandBrake/HandBrake/issues/77

For now I disabled x265.

segin commented on 2016-02-06 03:47

Typescript file: http://sprunge.us/dIYj

segin commented on 2016-02-06 03:45

Can you try again after installing package 'numactl' from the official ArchLinux repos? I have 2.0.11-1 installed, as it's a dependency of libvirt. Since the system's owner has a dependency on virtualisation, I don't have the authorisation to remove 'numactl' and the various packages that depend on it from the system.

It's what's causing the numa headers to be picked up by x265's configure script, and the subsequent linker failure.

P.S., I logged the build via 'script' and will upload the resultant typescript file shortly.

haawda commented on 2016-01-26 00:16

Cannot reproduce.