Package Base Details: gstreamer0.10-base

Git Clone URL: https://aur.archlinux.org/gstreamer0.10-base.git (read-only, click to copy)
Submitter: yurikoles
Maintainer: ava1ar
Last Packager: ava1ar
Votes: 117
Popularity: 2.89
First Submitted: 2017-01-26 13:45
Last Updated: 2017-10-04 05:04

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

yurikoles commented on 2017-02-15 13:54

@bu.domino may be its caused by package version bump?

bu.domino commented on 2017-02-14 22:49

For some reason "packer -Syu" defaults to trying to install this package even if the current package being worked on is something else entirely. Is the problem connected to this package or the aur helper?

yurikoles commented on 2017-02-14 18:27

@kozaki you welcome.

kozaki commented on 2017-02-14 18:19

Answering my last remark and question. From Arch's wiki:

If when trying to connect to a radio station you get the following error:

gstdecodebin2.c(3679): gst_decode_bin_expose (): /GstPlayBin2:player/GstURIDecodeBin:uridecodebin16/GstDecodeBin2:decodebin216:no suitable plugins found

Install the missing dependency:

pacman -S gstreamer0.10-ugly-plugins
--
After what it plays fine. Thank you yurikoles for maintaining the packages!

kozaki commented on 2017-02-11 15:22

Removing all infinality packages (but fonts themselves) allowed gstreamer0.10 PKGBUILD to build on my x86_64 machine. Thank you yurikoles for advising to do so!
Now there's an issue with decoding radio stations:

Error in Radio gstdecodebin2.C(6379): gst_decode_bin_expose (): /GstPlayBin2:player/GstURIDecodeBin:uridecodebin0/GstDecodeBin2:decodebin20

Does so with all my usual stations. Anyone with a related error?

hopimet commented on 2017-02-10 18:10

@Bujhm666,
I confirm. I got the same error on a 32 bit system but it still compiles on a 64 bit architecture.

Bujhm666 commented on 2017-02-10 18:04

I still do not compile. The latest version normally installed on a 32 bit system was 0.10.36-3.
-----------------------------
make[3]: *** [Makefile:696: libgstaudioresample_la-speex_resampler_float.lo] Error 1
make[2]: *** [Makefile:833: audioresample] Error 2
make[1]: *** [Makefile:678: all-recursive] Error 1
make: *** [Makefile:607: all] Error 2
==> Error: A failure occurred in build().
-----------------------------

yurikoles commented on 2017-02-10 13:36

@kozaki do you use infinality-patched packages? There was similar problem caused by infinality.

kozaki commented on 2017-02-09 21:11

Hi! gstreamer0.10-base-plugins won't compile too with the following error (LANG=C):

...
In file included from /usr/include/gtk-3.0/gtk/gtk.h:282:0,
from jsseek.c:38:
/usr/include/gtk-3.0/gtk/deprecated/gtkvbox.h:61:13: note: declared here
GtkWidget * gtk_vbox_new (gboolean homogeneous,
^~~~~~~~~~~~
make[4]: Leaving directory '/tmp/gstreamer0.10-base/src/gst-plugins-base/tests/examples/app'
CCLD scrubby
CCLD stepping
CCLD stepping2
/usr/lib/libharfbuzz.so.0: undefined reference to `FT_Get_Var_Blend_Coordinates'
collect2: error: ld returned 1 exit status
make[4]: *** [Makefile:581: scrubby] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory '/tmp/gstreamer0.10-base/src/gst-plugins-base/tests/examples/seek'
make[3]: *** [Makefile:837: seek] Error 2
make[3]: Leaving directory '/tmp/gstreamer0.10-base/src/gst-plugins-base/tests/examples'
make[2]: *** [Makefile:570: all-recursive] Error 1
make[2]: Leaving directory '/tmp/gstreamer0.10-base/src/gst-plugins-base/tests'
make[1]: *** [Makefile:678: all-recursive] Error 1
make[1]: Leaving directory '/tmp/gstreamer0.10-base/src/gst-plugins-base'
make: *** [Makefile:607: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build gstreamer0.10-base.

Archange commented on 2017-02-06 21:35

@baastrup I think you’re comment belongs to this package: https://aur.archlinux.org/packages/icaclient/.