Package Base Details: gmsh

Git Clone URL: https://aur.archlinux.org/gmsh.git (read-only)
Submitter: S1G1
Maintainer: gborzi
Last Packager: gborzi
Votes: 50
Popularity: 0.036653
First Submitted: 2006-04-04 23:31
Last Updated: 2019-09-24 15:12

Packages (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

gborzi commented on 2018-03-01 16:19

@simonp I'll switch to sha256sums at the next release.

simonp commented on 2018-02-26 22:54

Please do not use md5sum, this is unsafe. Please use sha256 instead. PKGBUILD with proper integrity checks: https://gist.github.com/simonpp/9c1ce4a4e89958669a4b01ae0bc4dffc

Thanks!

gborzi commented on 2018-01-12 23:38

With the latest openmpi update gmsh doesn't work anymore. The problem is solved recompiling and reinstalling med. No need to recompile gmsh.

gborzi commented on 2017-07-13 09:31

@soince
you need to recompile med. After installing the recompiled med gmsh will work without the need to recompile it.

solnce commented on 2017-07-13 08:49

Compiling version 3.0.3-1 fails for me.

[100%] Linking CXX shared library libGmsh.so
/usr/bin/ld: warning: libmpi_usempif08.so.11, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libmed.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libmpi_usempi_ignore_tkr.so.6, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libmed.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libmpi_mpifh.so.12, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libmed.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libmpi.so.12, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libmed.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libgfortran.so.3, needed by /usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libmed.so, not found (try using -rpath or -rpath-link)
/usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libmed.so: undefined reference to `_gfortran_st_write_done@GFORTRAN_1.0'
/usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libmed.so: undefined reference to `_gfortran_transfer_character_write@GFORTRAN_1.4'
/usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libmed.so: undefined reference to `_gfortran_transfer_integer_write@GFORTRAN_1.4'
/usr/lib/gcc/x86_64-pc-linux-gnu/7.1.1/../../../../lib/libmed.so: undefined reference to `_gfortran_st_write@GFORTRAN_1.0'
collect2: Fehler: ld gab 1 als Ende-Status zurück
make[2]: *** [CMakeFiles/gmsh.dir/build.make:25544: gmsh] Fehler 1
make[1]: *** [CMakeFiles/Makefile2:1193: CMakeFiles/gmsh.dir/all] Fehler 2
make[1]: *** Es wird auf noch nicht beendete Prozesse gewartet....
[100%] Built target shared
make: *** [Makefile:163: all] Fehler 2

gborzi commented on 2017-06-06 20:53

After the update to gcc-libs this package must be recompiled.

lahwaacz commented on 2017-04-13 09:44

The PKGBUILD hardcodes an explicit (and now outdated) python version:

install -D -m644 "${pkgdir}/usr/bin/onelab.py" "${pkgdir}/usr/lib/python3.5/site-packages/onelab.py"

mickele commented on 2017-03-07 22:02

After recent upgrade of mesa to version 17.0, I had the following error
Could NOT find OpenGL (missing: OPENGL_gl_LIBRARY)
I solved the issue adding
-DOPENGL_gl_LIBRARY=/usr/lib/mesa/libGL.so
to cmake options.

gborzi commented on 2016-11-02 14:08

@eolianoe
Fixed, thanks.

eolianoe commented on 2016-11-02 12:18

The cheksums are not good and with the right archive there is no need of the svn information ('svn-20161031'), see [a]

[a] http://onelab.info/pipermail/gmsh/2016/010909.html