Package Base Details: gmsh

Git Clone URL: https://aur.archlinux.org/gmsh.git (read-only, click to copy)
Submitter: S1G1
Maintainer: gborzi
Last Packager: gborzi
Votes: 52
Popularity: 1.43
First Submitted: 2006-04-04 23:31
Last Updated: 2020-07-03 14:21

Packages (2)

Anonymous comment on 2012-03-28 10:17

Hi gborzi, thanks for your effort. I still need to do -DENABLE_PETSC=0.

gborzi commented on 2012-02-13 14:54

@bashseb
I had some problems compiling petsc, it finally worked when I put !makeflags in options. Then I compiled gmsh and didn't get any error. Can you retry the build with petsc?

Anonymous comment on 2012-02-13 09:04

@gborzi, yes this works as a workaround. thanks a lot for your effort. appreciated.

gborzi commented on 2012-02-12 23:07

@bashseb
It seems you have petsc installed, and somehow it isn't working. I'm building petsc to check this problem. In the meantime, if you need to build gmsh add -DENABLE_PETSC=0 to the cmake line, i.e.
cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DENABLE_PETSC=0 ..

Anonymous comment on 2012-02-12 20:07

Dunno what I'm doing wrong, but I got:

-- Found PETSc
CMake Error at CMakeLists.txt:611 (string):
string sub-command REPLACE requires at least four arguments.
CMake Error at CMakeLists.txt:630 (string):
string sub-command REPLACE requires at least four arguments.

and ERROR in build().

gborzi commented on 2012-02-05 15:59

Updated for libpng 1.5.8

gborzi commented on 2011-12-24 15:21

This package builds with opencascade 6.5.2.

gborzi commented on 2011-03-16 21:41

Updated to work with opencascade 6.5.0.

gborzi commented on 2011-03-03 16:00

@domanov,
no, it isn't. But without opencascade you can't import BREP, STEP and IGES CAD files. If you don't want to compile opencascade, simply remove it from the depends array of gmsh PKGBUILD.

domanov commented on 2011-03-03 15:43

Is it really necessary to install opencascade?