Package Base Details: dolphin-emu-git

Git Clone URL: https://aur.archlinux.org/dolphin-emu-git.git (read-only, click to copy)
Keywords: dolphin emu emulator game gamecube gui nintendo remote revolution triforce wii wiimote
Submitter: None
Maintainer: dpeukert
Last Packager: dpeukert
Votes: 106
Popularity: 0.044258
First Submitted: 2011-08-20 13:05
Last Updated: 2021-01-10 20:26

Pinned Comments

dpeukert commented on 2020-04-10 12:34

The PKGBUILD for this package is hosted here (contributions are welcome!): https://gitlab.com/dpeukert/pkgbuilds/tree/main/dolphin-emu-git

TomBoshoven commented on 2012-04-20 12:23

I have the exact same problem as Alucryd.
It works after I patch CMakeLists:
http://pastebin.com/Uh4N6Dz9

Maybe you can check whether the build on your system works with this patch?

I don't think I have any strange configurations on my system. (default Arch flags for compiling, no strange additions to PATH)

Anonymous comment on 2012-04-20 11:21

@Alucryd: The bit you said about wxgtk is true: version 2.9.4 is required, and I removed it. But for your first problem, I tried to compile it and it secceeded. Everything that I installed and was to be dynamically linked worked out as expected. So I can't help about your problem. I suspect whether you had misconfigured some PATH or compile flags.

alucryd commented on 2012-04-20 10:12

Hey, probably not the best place to post this but can you guys reproduce this? http://pastebin.com/d0scausE
Several issues: bluez, pulseaudio and soil are installed on my system but not detected. sfml is installed and detected but dolphin still uses static version (not that I care, but it's intriguing). Finally an error about gthread-2.0, which is, from what I've read, part of glib2, and is installed.

BTW, you can remove the wxgtk dependency sgsdxzy. This requires at least 2.9.4 when arch's version is 2.8.12, adding a version requirement on wxgtk would simply break the package, so I think removing it is the best option, people who don't use wxgtk won't have to install it for nothing, and dolphin will still use its internal version.

Anonymous comment on 2012-04-09 10:06

@akspecs:The difference is here:_gitname=dolphin-emu vs_gitname=dolphin-emu-3.0. That's stable 3.0 released 9 months ago while this one is the latest git version. gcc4.7 changed behaviour slightly, and you need to include <unistd.h>. The 3.0 branch can't receive bugfixes, so the AUR maintainer added a patch. The gcc problem is said to be fixed and no patch is necessary for the git version.

akspecs commented on 2012-04-09 08:51

Here's the report I submitted :
http://code.google.com/p/dolphin-emu/issues/detail?id=5353

I noticed that the other dolphin-emu has been updated. At this point what makes dolphin-emu different from this PKGBUILD? Both fail to build on one of my systems, and both are looking like they're installing the latest that the git repo provides.

Anonymous comment on 2012-04-09 05:26

@akspecs:According to issue 5347, it's having problems with gcc4.7. But your problem doesn't look like that. I will have a try later. Please consider report an issue upstream.

akspecs commented on 2012-04-09 03:47

Any help would be appreciated - I'm running on the ck kernel with propietary nvidia graphics:

/tmp/yaourt-tmp-aak/aur-dolphin-emu-git/src/dolphin-emu/Externals/wxWidgets3/include/wx/filefn.h:476:9: error: zero width for bit-field ‘wxAssert_477::BadFileSizeType’
make[2]: *** [Externals/wxWidgets3/CMakeFiles/wx.dir/src/aui/auibar.cpp.o] Error 1
make[1]: *** [Externals/wxWidgets3/CMakeFiles/wx.dir/all] Error 2
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build dolphin-emu-git.

akspecs commented on 2012-04-09 03:46

/tmp/yaourt-tmp-aak/aur-dolphin-emu-git/src/dolphin-emu/Externals/wxWidgets3/include/wx/filefn.h:476:9: error: zero width for bit-field ‘wxAssert_477::BadFileSizeType’
make[2]: *** [Externals/wxWidgets3/CMakeFiles/wx.dir/src/aui/auibar.cpp.o] Error 1
make[1]: *** [Externals/wxWidgets3/CMakeFiles/wx.dir/all] Error 2
make: *** [all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build dolphin-emu-git.

alucryd commented on 2012-03-09 20:05

Okay, turns out the culprit was cache display lists, I'll post an issue on google code.

alucryd commented on 2012-03-09 19:54

Hey huys, I've got a problem running dolphin here. Everything builds fine with gcc 4.6.3, I'm using xorg 1.11.4 with latest fglrx (direct rendering works) and the linux-ck kernel, however the emu will shut down without any error almost immediately on a lot of games. Most of the time it's right after intro the video or static screens, it crashes silently before displaying some 3D sequences. Like the title screen in Zelda WW and TP, SMG, SSBB etc... Only game I tested that worked so far is Final Fantasy Crystal Chronicles. It doesn't crash at all.
I can't provide any log because they're empty, I'm really at a loss here. Does any of you have the same issue?