Package Base Details: darling-git

Git Clone URL: https://aur.archlinux.org/darling-git.git (read-only, click to copy)
Keywords: Darwin Emulator macOS OSX Wine
Submitter: Xorg
Maintainer: jamesbrink
Last Packager: jamesbrink
Votes: 34
Popularity: 0.001098
First Submitted: 2013-06-29 15:19
Last Updated: 2020-07-26 04:35

Pinned Comments

jamesbrink commented on 2019-07-10 02:27

Please use this package for stable more reliable builds

https://aur.archlinux.org/packages/darling/

This one is identical but locked in on a last known working git ref and I will update as often as I can.

I have also raised an issue about versioning so maybe we can get some kind of tags for future versions and stable working builds

https://github.com/darlinghq/darling/issues/537

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10 11 12 13 14 Next › Last »

wenLiangcan commented on 2016-02-26 01:33

@Xorg thank you, it worked now!

Xorg commented on 2016-02-25 15:55

Sorry to answer one week later... org.darlinghq.pkg.PrefixHierarchy has been removed in latest source code.

After loading darling-mach, you need to change permissions on /dev/mach (e.g. chmod a+rw /dev/mach).

wenLiangcan commented on 2016-02-19 12:56

Are there any programs to test whether darling worked? I tried to run this tool (https://github.com/Kapeli/javadocset) and got the error below from the terminal:

Getting latest version of org.darlinghq.pkg.PrefixHierarchy...
Downloading org.darlinghq.pkg.PrefixHierarchy (version 1)...
Cannot open /dev/mach. Aborting.
Make sure you have loaded the darling-mach kernel module.
/usr/bin/darling: line 42: 12747 Aborted (core dumped) "${DARLING_PREFIX}/libexec/darling/usr/bin/installer" -pkg "/system-root${pkgpath}" -target /


darling-mach is already loaded on my system.

Xorg commented on 2016-02-14 13:26

Due to recent changes on upstream, I'm rewriting this package (I think build is broken).
Tell me if you need audio support (disable by default).

Xorg commented on 2015-10-23 18:58

Patch send on upstream, see this pull request: https://github.com/darlinghq/darling/pull/94

yan12125 commented on 2015-10-23 18:26

I got the same error as https://github.com/darlinghq/darling/issues/93 and maz-1's fix works for me. Could you pull it?

Xorg commented on 2015-03-22 09:25

Ok, great, thank for the issue on GitHub.

Darling's packages now depend of 'clang35' for building.

yan12125 commented on 2015-03-22 08:34

Build failure after LLVM updated to 3.6.0. It's an upstream bug. I've reported here: https://github.com/LubosD/darling/issues/85

Xorg commented on 2015-03-09 13:43

It's useless to report twice the same problem, and because Darling hasn't been modified since a long time.
If gnustep-make-multilib-clang-svn is installed, it doesn't cause problem for darling-multilib-git because darling-multilib-git doesn't need it.

toddpi314 commented on 2015-03-09 06:13

warning: Looks like https://aur.archlinux.org/packages/gnustep-make-multilib-clang-svn/ might not be compatible with latest deps anymore