Package Base Details: catalyst-utils

Git Clone URL: https://aur.archlinux.org/catalyst-utils.git (read-only)
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 61
Popularity: 0.000057
First Submitted: 2013-04-29 09:04
Last Updated: 2018-04-29 16:46

Pinned Comments

Vi0L0 commented on 2017-03-14 19:40

about 4.9 and 4.10 kernel support - looks like to make it work correctly with fglrx you have to blacklist amdgpu ie.:

# cat /etc/modprobe.d/blacklist.conf
blacklist amdgpu

Vi0L0 commented on 2017-03-14 19:32

catalyst is old and it supports only up to xorg-server 1.17, you can get it from repo:

[xorg117]
Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch

add it to pacman.conf above other repositories and perform downgrade:
pacman -Syuu

catalyst will not support newer versions of xorg-server, like ever.
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

Vi0L0 commented on 2017-03-11 18:30

If you see this conflict:

looking for conflicting packages...
:: mesa and catalyst-libgl are in conflict (mesa-libgl). Remove catalyst-libgl? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: mesa and catalyst-libgl are in conflict

for now I've added mesa packages of 17.0.1-1 version to [catalyst]* and [catalyst-stable] - simply copied from archive: https://archive.archlinux.org/packages/

Please downgrade if you updated mesa to -2 version.
After new version of mesa came out, I will build new mesa packages without glvnd support. Then I will most probably add new mesa package to aur. Will let know when it will happen

*
[catalyst]
Server = http://mirror.hactar.xyz/Vi0L0/catalyst/$arch

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7

goviedo commented on 2013-09-26 23:28

error: target not found: xorg-server<1.14.0
==> ERROR: 'pacman' failed to install missing

[root@arch Downloads]# Xorg -version

X.Org X Server 1.14.3
Release Date: 2013-09-12

Since the last upgrade to my Arch x64. This is a problem!

Vi0L0 commented on 2013-09-19 19:24

guys, 13.9 has memory leak, it's not stable at all.
AMD could say otherwise but don't listen to them :P

you will find 13.9 at catalyst-test and catalyst-test-pxp @ AUR,
and maybe tomorrow on the [catalyst] repo

Anonymous comment on 2013-09-14 06:34

@Vi0L0
Ok, thx!

Vi0L0 commented on 2013-09-08 14:23

@olive:
looks like you are right, thanks for the fix, I've already included it into catalyst 13.8 beta 2 packages, when time for the update will come I will add it also here

@icebreaker90 && @canatan:
changing dependency won't force this driver to work with xserver 1.14... catalyst 13.4 doesn't support xserver 1.14 and nothing will change it :P.
You can use beta drivers (like catalyst-test) if you need to work on/with xserver 1.14. But beta is beta, it's buggy and unstable - on some hardware it works better, on some it works way worse.
This is the place for stable _catalyst_ release, and latest (in both theoretical and practical point of view) stable release is 13.4.

canatan commented on 2013-08-31 12:46

@icebreaker90 +1

Anonymous comment on 2013-08-27 14:17

Please change dependency for xorg-server because 1.14.2-2 has been moved to stable channel.
Thanks

olive commented on 2013-08-22 14:14

There is a bug /etc/ati/authatieventsd.sh for xdm (not much used anymore, but it is better that all works fine).

The variable XDM_AUTH_MASK (l37)
XDM_AUTH_MASK=/var/lib/xdm/authfiles/A$1*
should be replaced by:
XDM_AUTH_MASK=/var/lib/xdm/authdir/authfiles/A$1*

otherwise the script does not file the auth file and atieventsd cannot access to the Xserver (as can be seen in the system log).

Vi0L0 commented on 2013-06-01 12:27

updated to 13.4-2:
- all bins have been moved to /usr/bin
- added workaround for i/o bug

Vi0L0 commented on 2013-05-27 18:56

It seems to work fine here on 7850,
are you runing those when X serv is running?

cgminer version 3.1.1 - Started: [2013-05-27 20:46:54]
GPU0 | (5s):0.000 (avg):246.0Mh/s | A:12 R:0 HW:0 U:6.8/m I: 5


Are you using ocl_memtest from cuda_memtest package?
using here 1.2.3 version of this package without problems:
$ ocl_memtest
hostname is xaos
CL_PLATFORM_NAME: AMD Accelerated Parallel Processing
CL_PLATFORM_VERSION: OpenCL 1.2 AMD-APP (1124.2)
Device 0 is CL_DEVICE_TYPE_GPU, "Pitcairn"
allocated 512 Mbytes from device 0
[05/27/2013 20:54:36][xaos][0]:Test0 [Walking 1 bit]
[05/27/2013 20:54:36][xaos][0]:Test0: global walk test
[05/27/2013 20:54:36][xaos][0]:Test0: local walk test
[05/27/2013 20:54:36][xaos][0]:Test0 finished in 0.0 seconds
[05/27/2013 20:54:36][xaos][0]:Test1 [Own address test]
... and so on...

unforgiven512 commented on 2013-05-17 06:35

Something seems to be wrong with OpenCL here.

cgminer (and cgminer-git) report:
[2013-05-17 02:34:35] GPU0: invalid nonce - HW error

cuda_memtest reports:
[unforgiven512@dilaudid]:~$ ocl_memtest
hostname is dilaudid
CL_PLATFORM_NAME: AMD Accelerated Parallel Processing
CL_PLATFORM_VERSION: OpenCL 1.2 AMD-APP (1124.2)
Device 0 is CL_DEVICE_TYPE_GPU, "Barts"
ERROR: opencl call failed with rc(-11), line 385, file ocl_memtest.cpp
Error: Program build failure