Package Base Details: catalyst-utils

Git Clone URL: https://aur.archlinux.org/catalyst-utils.git (read-only)
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 61
Popularity: 0.000491
First Submitted: 2013-04-29 09:04
Last Updated: 2018-04-29 16:46

Pinned Comments

Vi0L0 commented on 2017-03-14 19:40

about 4.9 and 4.10 kernel support - looks like to make it work correctly with fglrx you have to blacklist amdgpu ie.:

# cat /etc/modprobe.d/blacklist.conf
blacklist amdgpu

Vi0L0 commented on 2017-03-14 19:32

catalyst is old and it supports only up to xorg-server 1.17, you can get it from repo:

[xorg117]
Server = http://mirror.hactar.xyz/Vi0L0/xorg117/$arch

add it to pacman.conf above other repositories and perform downgrade:
pacman -Syuu

catalyst will not support newer versions of xorg-server, like ever.
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

Vi0L0 commented on 2017-03-11 18:30

If you see this conflict:

looking for conflicting packages...
:: mesa and catalyst-libgl are in conflict (mesa-libgl). Remove catalyst-libgl? [y/N] n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: mesa and catalyst-libgl are in conflict

for now I've added mesa packages of 17.0.1-1 version to [catalyst]* and [catalyst-stable] - simply copied from archive: https://archive.archlinux.org/packages/

Please downgrade if you updated mesa to -2 version.
After new version of mesa came out, I will build new mesa packages without glvnd support. Then I will most probably add new mesa package to aur. Will let know when it will happen

*
[catalyst]
Server = http://mirror.hactar.xyz/Vi0L0/catalyst/$arch

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

averagejoey2000 commented on 2014-12-08 20:35

pacaur and yaourt cannot satisfy the following dependency:
xorg-server (less than)<1.16
that is simultaneously >=(greater than or equal to) 1.7
Do I need to install a specific xorg, modify the PKGBUILD for this(catalystutils), or what?

ShyPixie commented on 2014-10-23 11:54

This package need a patch for amdxdg-su work with xfce.

The script check if environments match with xfce4 (see line 323), but not in final "case" (on lines 566 ~ 587).

Need to edit script on the last case/esac with:

xfce4)
su_gnome
;;

Vi0L0 commented on 2014-10-03 20:55

updated to 14.9-1:
- official, stable release
http://support.amd.com/en-us/kb-articles/Pages/AMDCatalyst14-9LINReleaseNotes.aspx

- it doesn't support xserver 1.16

- I added my fresh patch for kernel 3.17 rc6.
Notes about the patch:
1. it probably wont work on 3.17 kernels older than rc6 because I don't know how to tell preprocessor about rc version :P
2. im unable to test resume/suspend
3. im not the developer, just pressing random keys :P so the patch could be less/more noobish :-)

kamelie1706 commented on 2014-07-30 08:49

Thanks, will use [xorg115] repo for now.

Vi0L0 commented on 2014-07-30 08:13

Right now only one person had enought luck to run newest, beta catalyst on xorg-server 1.16.

I checked it on 2 AMD GPUs, getting X crash with error: libglx.so: undefined symbol: LoadExtension, others also weren't able to run it succesfully.

I think that you can skip checking and simply use [xorg115] repo:
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

Vi0L0 commented on 2014-07-30 08:08

Right now only one person had enought luck to run newest, beta catalyst on xorg-server 1.16.
I checked it on 2 AMD GPUs, others also weren't able to run it succesfully.
I think that you can skip checking and simply use [xorg115] repo:
https://wiki.archlinux.org/index.php/AMD_Catalyst#Xorg_repositories

kamelie1706 commented on 2014-07-30 07:17

I installed
catalyst-utils
catalyst-libgl
opencl-catalyst

using
* pacman -Sy * for each package - no error

but
* sudo pacman -Syu *
still complains the same

kamelie1706 commented on 2014-07-30 07:09

I probably missed something as I was off for a month.
When trying
* sudo pacman -Syu *
it complains about catalyst-utils requires xorg-server<1.16.0
I use currently X.Org X Server 1.15.2

AlfredoRamos commented on 2014-07-29 20:58

Hi there,

I can't upgrade because I have xorg-server 1.16.0-5 installed, it's still 1.16.0 though.

Does catalyst-utils work with this version of xorg-server? Is there any way to upgrade?

PS: I'm using the unofficial repository.

- https://wiki.archlinux.org/index.php/Unofficial_user_repositories#catalyst

Vi0L0 commented on 2014-07-26 16:51

Thank You NoSuck.
I did a silent update (libgl's install is just the echo, so there was no reason to bump pkgrel) which fixed it.
Also I removed split hack, because for some time aur supports split packages.
(I performed same update on lib32-catalyst-utils)