Package Base Details: amdgpu-pro-installer

Git Clone URL: https://aur.archlinux.org/amdgpu-pro-installer.git (read-only, click to copy)
Submitter: LEW21
Maintainer: Ashark
Last Packager: Ashark
Votes: 104
Popularity: 1.30
First Submitted: 2016-03-28 22:44
Last Updated: 2021-07-07 08:23

Pinned Comments

Ashark commented on 2019-12-09 20:52

PKGBUILD generator is located here: https://github.com/Ashark/archlinux-amdgpu-pro

AMDGPU PRO wiki page: https://wiki.archlinux.org/index.php/AMDGPU_PRO

Latest Comments

« First ‹ Previous ... 6 7 8 9 10 11 12 13 14 15 16 ... Next › Last »

panospolychr commented on 2020-04-24 09:56

@hedgepigdaniel I tried to make amdgpu-pro 20.10 packages using your PKGBUILD but i'm getting this message "==> ERROR: install file (amdgpu-core-meta.install) does not exist or is not a regular file."

kode54 commented on 2020-04-20 01:24

Would there be any point to supporting the DKMS packages contained within? One of them contains a different version of the AMDGPU kernel module, while the other contains its own copy of AMD's firmware blobs.

ThomasZeGerman commented on 2020-04-19 15:42

installing this package makes my sddm coredump when it tries to create a opengl context

hedgepigdaniel commented on 2020-04-18 07:24

@kode54 No one has pushed anything out, hence why this package is out of date, and even if they had, they would have no responsibility at all to you.

For the record, AMF video encoding works for me with the PKGBUILD I posted, but installing the libgl packages broke GDM.

kode54 commented on 2020-04-18 07:11

Verified the the 20.10.1048557 does not have working libGL or ORCA OpenCL on my RX 480. Does anyone even test these things before attempting to push them out?

hedgepigdaniel commented on 2020-04-18 05:28

Here's and updated PKGBUILD (modified from @neatherm's one) for the released (not preview) 20.10 version: https://gist.github.com/hedgepigdaniel/193076ee30bb89edcf8650314ba33699

kode54 commented on 2020-03-29 09:07

Yeah, I'm gonna call crap on the 20.10 EPB. Any attempt to use Blender to render using it, and my whole GPU locks up the PCIe bus. If I don't quickly switch to a TTY to kill Blender, my desktop will just lock up, period.

The 19.50 Orca driver works fine on my RX 480, though.

kode54 commented on 2020-03-29 04:58

How many of the packages have you installed? I only installed:

amdgpu-core-meta
amdgpu-pro-core-meta
amdgpu-pro-libgl
lib32-amdgpu-pro-libgl
opencl-amdgpu-pro-orca
vulkan-amdgpu-pro
lib32-vulkan-amdgpu-pro

Using an RX 480. I’ve also kind of stopped using Linux for now, since within 20 minutes of booting I now get a pcie bus error with my gpu and kernel panic.

naetherm commented on 2020-03-28 05:55

@kode54: Really? I'm also using gdm without any problems.

kode54 commented on 2020-03-27 06:52

@naetherm I still can't make the libgl packages work with gdm, logging out of my desktop after installing them results in gdm crashing itself. The Vulkan drivers work, as do the Orca OpenCL drivers.