Package Base Details: amdapp-sdk

Git Clone URL: https://aur.archlinux.org/amdapp-sdk.git (read-only, click to copy)
Submitter: Vi0L0
Maintainer: rigred
Last Packager: satcom886
Votes: 83
Popularity: 0.000055
First Submitted: 2013-02-11 21:03
Last Updated: 2019-08-16 21:33

Latest Comments

« First ‹ Previous ... 4 5 6 7 8 9 10 11 12 13 14 ... Next › Last »

big_gie commented on 2012-05-02 16:25

IIRC clinfo was built with OpenCL v1.1 functions while amd's driver is only 1.0, so it crashes when trying.
clinfo runs fine on an nvidia system. In that case it's just a poorly written clinfo. Take a look at my oclutils: https://github.com/nbigaouette/oclutils/

Anonymous comment on 2012-05-02 16:22

/opt/amdstream/bin/clinfo is crashing with segmentation fault? I re-install catalyst-hook. Any ideas to fix this problem?

Anonymous comment on 2012-04-14 01:23

Can be adapted to ccr?

Anonymous comment on 2012-04-11 23:34

@nplatis meh, that's a stupid bug in yaourt.

In order to save time and energy i set PKGEXT to ".tar.gz". Yaourt ist ignoring this and tries to install pkgname.pkg.tar.xz.
So manually issuing pacman -U /tmp/<path>/*tar.gz will install the package.

nplatis commented on 2012-04-11 23:13

Cannot install the package. Using yaourt, building seems to be OK, but installation fails with the message:
'/tmp/yaourt-tmp-root/PKGDEST.fck/*.pkg.tar.xz': cannot find or read package

Anonymous comment on 2012-04-04 00:05

weird readlink()-compile error
worked around by including unistd.h -> 2.6-2

Anonymous comment on 2012-01-11 22:10

kralyk has handed the package to me, so I could merge the changes into the PKGBUILD.
Therefore I removed the patch files from my webserver.

Anonymous comment on 2011-12-22 12:01

APP 2.6 is out

Since there a couple of issues now I modified the PKGBUILD slightly:
+ include app 2.6
+ include ICD reference again
+ include symlink for clinfo
+ removed empty-source-archive workaround ( isn't it simpler to just extract the sub-archive in build() ? )
+ renamed OVDecode to OpenVideo
+ added implicit linking patch ( fixes old GL and new introduced X11 linking error )

relevant files:
http://little.dyn-o-saur.com/files/app/PKGBUILD
http://little.dyn-o-saur.com/files/app/01-implicit-linking.patch

optional file:
http://little.dyn-o-saur.com/files/app/PKGBUILD.diff

happy holidays everyone

giniu commented on 2011-12-19 16:04

I also vote for inclusion of icd, I use amd stream only for CPU as I have nVidia GPU, but I'd still would like to be able to use my Phenom with simple OpenCL apps - without installing catalyst-utils.

Anonymous comment on 2011-12-17 22:35

Please include the creation of the icd reference in /etc/OpenCL/vendors again.

Otherwise people who want to code/test on x86 only will tend to install catalyst-utils and that's just bananas.