Package Details: zulucrypt 5.7.1-1

Git Clone URL: https://aur.archlinux.org/zulucrypt.git (read-only, click to copy)
Package Base: zulucrypt
Description: A cli and gui frontend to cryptsetup
Upstream URL: https://github.com/mhogomchungu/zuluCrypt/
Keywords: cryptsetup encryption security tcplay truecrypt veracrypt
Licenses: GPL
Conflicts: zulucrypt-git
Submitter: salan54
Maintainer: salan54
Last Packager: salan54
Votes: 58
Popularity: 1.07
First Submitted: 2013-02-03 13:05
Last Updated: 2020-02-06 09:52

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

salan54 commented on 2017-11-01 16:34

@egrupled: No prob : your comments are welcome and constructive.
I already tried sometime ago to remove zulucrypt.install and zulucrypt.changelog from the AUR git tree. I know they are not relevant anymore... but I screwed up my remote git repository ;-) Will try again later !

As we use to say in french : "Le temps porte conseil !...". I did succeed and think the AUR git tree is clean !

egrupled commented on 2017-11-01 15:08

@salan54 Thanks for update.

I know that install hook is unused here but it would be nice to delete it from AUR repos completely. Changelog can be also removed from PKGBUILD and deleted from repo as it's already outdated and I doubt that anyone needs it installed with package. I also doubt if including md5sum is useful in PKGBUILD. Most of this as applicable to -git version too.

I hope I'm not annoying you with those advice. My intention isn't pushing anything, those are minor things for completeness. You do a great job anyway :)

salan54 commented on 2017-11-01 13:32

version 5.3.0
-- fix a build time error when build with certain new compilers and a runtime crush when build with other newer compilers.
-- add more support for wayland sessions by not requiring GUI to run from root's account to perform some operations.
-- add support for creating LUKS2 volumes(libcryptsetup >=2.0.0 is required)
-- add support for unlocking of TrueCrypt and VeraCrypt volumes without mounting their file system.
-- unlocking of a TrueCrypt volume is done by command: zuluCrypt-cli -O -d /dev/sdXX -t tcrypt
-- unlocking of a VeraCrypt volume is done by command: zuluCrypt-cli -O -d /dev/sdXX -t vcrypt

salan54 commented on 2017-10-29 09:54

@egrupled: Thanks for your advices. I will implement them in a future update.

egrupled commented on 2017-10-28 17:58

On next update please remove zulucrypt.install as its hook is already included in https://www.archlinux.org/packages/extra/x86_64/desktop-file-utils/ and redundant.

Also I don't see the need of:
options=('!buildflags')
line. The package builds correctly with default arch buildflags and those should be used as default. If someone uses non-standard buildlflags which break this package then it can be fixed locally.

All of above is applicable to -git version too.

0x0 commented on 2017-07-24 14:11

Ran into a problem while compiling:

/usr/lib/libharfbuzz.so.0: undefined reference to `FT_Get_Var_Blend_Coordinates'
collect2: error: ld returned 1 exit status
make[2]: *** [zuluCrypt-gui/CMakeFiles/zuluCrypt-gui.dir/build.make:1654: zuluCrypt-gui/zuluCrypt-gui] Error 1
make[1]: *** [CMakeFiles/Makefile2:994: zuluCrypt-gui/CMakeFiles/zuluCrypt-gui.dir/all] Error 2
make: *** [Makefile:128: all] Error 2

workaround:
sudo pacman -S --asdeps freetype2 cairo fontconfig

source for workaround:
https://www.reddit.com/r/archlinux/comments/5mphpu/psa_harfbuzz_update_infinality_breaking_system/

..works for me.

salan54 commented on 2017-07-10 09:43

@egrupled: fixed. Thanks for your help. I would better not work so late;-)

egrupled commented on 2017-07-10 09:21

There is typo in new PKGBUILD:

-D5CMAKE_BUILD_TYPE=release
should be:
-DCMAKE_BUILD_TYPE=release

egrupled commented on 2017-07-06 21:29

@salan54 That's reasonable. Thanks.

salan54 commented on 2017-07-06 18:45

@egrupled : this is the conversation I had with the developer about KDE and Gnome flags :

"I looked at the PKGBUILD file this morning before the request was made
and i though the same too,that the option should be "NOKDE=false" if
present but it should be removed all together.

I think both NOGNOME and NOKDE options should not be present in the
PKGBUILD file. This way, support for libsecret and kde wallet will be
auto enabled when they are found to be present and disabled when they
are found to be absent.

Just don't mention kwallet in a list of dependencies to avoid dragging
it in as a forced dependency but libsecret forced dependency should
stay since it doesnt drag in that much.

This way,those who want KDE integration can install kwallet first and
then build zuluCrypt and zuluCrypt will pick it up automatically."

I will remove the KDE and Gnome flags from the PKGBUILD. Of course, you can always edit the PKGBUILD to fulfil your needs.