Package Details: zulucrypt-git 5.5.0-1

Git Clone URL: https://aur.archlinux.org/zulucrypt-git.git (read-only, click to copy)
Package Base: zulucrypt-git
Description: a cli and gui frontend to cryptsetup.
Upstream URL: https://github.com/mhogomchungu/zuluCrypt/
Keywords: cryptsetup encryption security tcplay truecrypt veracrypt
Licenses: GPL
Conflicts: zuluCrypt
Provides: zuluCrypt
Submitter: salan54
Maintainer: salan54
Last Packager: salan54
Votes: 6
Popularity: 0.000000
First Submitted: 2013-03-12 14:23
Last Updated: 2019-05-02 13:25

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

mhogomchungu commented on 2015-02-03 13:19


This problem was first noticed and fixed in the released version[1] and the same fixed should be done here.

You can either wait for the maintainer to update the package or you can try to fix it yourself in the man time by making the necessary change.

The needed change is to substitute

cmake -DCMAKE_INSTALL_PREFIX=/usr/ -DNOKDE=true -DCMAKE_BUILD_TYPE=release . ..

with:

cmake -DCMAKE_INSTALL_PREFIX=/usr/ -DLIB_SUFFIX=lib -DNOKDE=true -DCMAKE_BUILD_TYPE=release . ..

as discussed there.

[1] https://aur.archlinux.org/packages/zulucrypt

orschiro commented on 2015-02-03 12:57

Dear salan54,

I fail to install this package. The zulucrypt package install fine, however.

error: failed to commit transaction (conflicting files)
zulucrypt-git: /usr/lib64 exists in filesystem
Errors occurred, no packages were upgraded.

How can I circumvent the issue?

Thankfully,

Robert

salan54 commented on 2014-02-01 17:20

Added a dep : tcplay (now in 'community' repository)

salan54 commented on 2013-11-29 09:56

zulucrypt-git 4.6.7-2 :
Changed dep from "libgnome-keyring" to "libsecret"

salan54 commented on 2013-11-23 17:34

Changed upstream to Github from Google Code
Updated to 4.6.7+git :
version 4.6.6
-- fix a regression,retrieving keys from kwallet using volume UUID broke.
-- volumes in gnome are now stored in libsecret and no longer in libgnome-keyring
-- add a GUI window in zuluCrypt-gui to manage keys in libsecret wallet,internal wallet and kde kwallet.
-- add an internal system that can securely store keys independently of kde kwallet and gnome libsecret.Useful to those who
want to store keys securely but dont want gnome or kde dependencies
-- add compile time option to use mount points in user home directory instead of "/run/media/private"
-- NOTE: changes in management of wallets are not backward compatible and hence volumes will have to be readded after the update.My
apologies for the inconvenience.
-- drop support for updating /etc/mtab and remove libmount as a required dependency
-- add a Qt5 port,see build instrunctions on how to build Qt5 version

version 4.6.7
-- fix packaging issues
-- fix a regression on zuluMount-gui that caused a hang when checking for properties of an opened volume opened by a different user

salan54 commented on 2013-09-09 21:06

Updated to 4.6.5+git :
-- fix a regression,retrieving keys from kwallet using volume UUID broke.
-- volumes in gnome are now stored in libsecret and no longer in libgnome-keyring
-- add a GUI window in zuluCrypt-gui to manage keys in libsecret wallet,internal wallet and kde kwallet.
-- add an internal system that can securely store keys independently of kde kwallet and gnome libsecret.Useful to those who want to store keys securely but dont want gnome or kde dependencies
-- NOTE: changes in management of wallets are not backward compatible and hence volumes will have to be readded after the update.My apologies for the inconvenience.

salan54 commented on 2013-09-09 09:22

Updated to 4.6.6 :
-- fix a regression,retrieving keys from kwallet using volume UUID broke.
-- volumes in gnome are now stored in libsecret and no longer in libgnome-keyring
-- add a GUI window in zuluCrypt-gui to manage keys in libsecret wallet,internal wallet and kde kwallet.
-- add an internal system that can securely store keys independently of kde kwallet and gnome libsecret.Useful to those who want to store keys securely but dont want gnome or kde dependencies
-- NOTE: changes in management of wallets are not backward compatible and hence volumes will have to be readded after the update.My apologies for the inconvenience.

salan54 commented on 2013-09-02 17:09

Updated to 4.6.5

salan54 commented on 2013-06-11 10:52

PKGBUILD updated to pacman4.1 recommendations

salan54 commented on 2013-06-11 10:51

PKGBUILD updated to pacman4.1 recommandations